1115 Counting Nodes in a BST (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤) which is the size of the input sequence. Then given in the next line are the N integers in [ which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n
 

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28
 

Sample Output:

2 + 4 = 6

已知二叉排序树的插入顺序,求解最后两层节点的和。

#include <iostream>
using namespace std;
struct node {
    int val;
    node *left, *right;
    node(int v): val(v), left(NULL), right(NULL) {}
}*root;
int arr[1000] = {0}, max_level = 0;
node* insert(node* root, int data, int level) {
    if(root == NULL) {
        max_level = max(max_level, level);
        arr[level]++;
        root = new node(data);
    }
    else if(data <= root->val) root->left = insert(root->left, data, level + 1);
    else root->right = insert(root->right, data, level + 1);
    return root;
}
int N, tmp;
int main() {
    scanf("%d", &N);
    while(N--) {
        scanf("%d", &tmp);
        root = insert(root, tmp, 0);
    }
    printf("%d + %d = %d\n", arr[max_level], arr[max_level - 1], arr[max_level] + arr[max_level - 1]);
    return 0;
}

 

posted @ 2020-05-09 12:32  SteveYu  阅读(174)  评论(0编辑  收藏  举报