09 2018 档案
摘要:因为从Spring Boot 1.4开始,spring boot就不支持log4j了,必须是log4j2或者logback,具体两者如何配置以及NDC的支持可以参考spring boot精华版。 这里要讲的是如果刚好用的spring boot是1.4+或者应用使用了log4j2,但是依赖的三方使用的
阅读全文
摘要:在spring boot中,支持多种定时执行模式(cron, fixRate, fixDelay),在Application或者其他Autoconfig上增加@EnableScheduling注解开启。 然后在指定方法增加@Scheduled注解,如下: 需要注意的是,如果在多个函数上使用了@Sch
阅读全文
摘要:今天测试的时候,启动一个其他机器预编译好的nginx到目标测试机器(OEL 7.4)启动的时候,报了下列错误: /usr/local/nginx/sbin/nginx: error while loading shared libraries: libpcre.so.0: cannot open s
阅读全文
摘要:最近使用物化视图同步的环境在大量刷新的时候频繁出现enq: JI – contention等待事件,经查: JI enqueue is acquired in exclusive mode on the mview base (container) table when more than one
阅读全文
摘要:之前没特别注意,在有些场景下希望使用并行索引扫描的时候,发现parallel_index hint并没有生效,于是抽空看了下文档:The PARALLEL_INDEX hint instructs the optimizer to use the specified number of concur
阅读全文
摘要:需要手工安装p13390677_112040_Linux-x86-64_6of7.zip,或者win32_11gR2_examples.zip。默认不包含。 从Oracle Database 12c Release 2开始,$ORACLE_HOME/demo/schema/human_resourc
阅读全文
摘要:最近在制作我们系统的发布包时,整理到ftp的时候,发现我们使用的是ssh模式进行文件传输的,而不是RFC 959的ftp,于是查了下,发现存在两种模式的文件传输模式,FTP和SSH。 第一个RFC的FTP协议发布通过网络使用FTP协议(由RFC 959或更高版本)的文件传输始于1980年,FTP提供
阅读全文
摘要:一直以来,都习惯于tnsping alias测试确定使用了那个sqlnet.ora,并测试连通性。最近在制作系统的安装包,为了轻量级以及提高实施效率,全部客户端使用oracle instant client,可惜并没有tnsping,于是研究了下如何用sqlplus测试连通性。看sqlplus -H
阅读全文
摘要:最近使用instant sqlplus测试时,遇到ora-12705,一开始以为是少了配置,经查是,NLS_LANG设置问题,设置为"SIMPLIFIED CHINESE_CHINA.ZHS16GBK"即可。
阅读全文
摘要:gdb调试程序函数名为问号,什么原因? http://bbs.chinaunix.net/thread-1823649-1-1.html http://www.bubuko.com/infodetail-1877415.html 其实就是3个原因:源代码和可执行程序版本不一致;没有符号表,这不只是-
阅读全文
摘要:版本介绍 目前最新版本为2.3(20190808更新)。demo搭建可参见https://www.orchome.com/6,收发消息测试可见https://www.cnblogs.com/yoyo1216/p/14024427.html。 从使用上来看,以0.9为分界线,0.9开始不再区分高级(相
阅读全文
摘要:最近在oracle linux 7.3下开发了个应用,发布到rhel 6.5运行的时候,报version `GLIBC_2.14' not found (required by /usr/lib64/libstdc++.so.6)以及libstdc++.so.6: version GLIBCXX_3
阅读全文
摘要:前一天在测试一个数据导出的时候,发现oci7编译的时候报了一大堆类似"’oparse’未定义的引用问题",这通常是因为找不到实现库的原因,但是oci相关的库又都是存在的,用oci7的接口就没有问题,找了很久都没找到,于是只能怀疑是oci7的接口c++无法兼容,于是将编译器从g++改成gcc,还是这个
阅读全文
摘要:服务端共享目录 /home/XXX/nfs_shared 172.16.22.0/24(rw,no_root_squash) service nfs restart 常用命令: 查看所有nfs共享目录: 当系统管理员对/etc/exports文件进行设置修改后并不会自动在NFS服务器中生效。NFS服
阅读全文
摘要:最近一直在处理新系统的性能优化问题,这两天特地测试了下oracle 11gR2开始引入的smart flash cache。 其介绍参考MOS文档,How To Size the Database Smart Flash Cache (文档 ID 1317950.1) The Database Sm
阅读全文
摘要:因为人员紧缺,最近又忙着去搞性能优化的事情,有时候真的是不想再搞这个事情,只是没办法,我当前的绩效几乎取决于这个项目的最终成绩,所以不管是人的事还是事的事,都得去让他顺利推进。 前段时间发生还有几台服务器晚上10点多awr里面还一直在跑DBMS_SCHEDULER的任务,如下: 对于11g版本的or
阅读全文
摘要:下午有个测试环境测试人员反馈oracle监听起不来,一启动就报错,还生成了core文件。如下: 经查,有下列解决方法: 重新链接oracle如下: [oracle:test]/bin$ cd /test/oracle/11.2.0.4/bin[oracle:test]/bin$ ./relink a
阅读全文
摘要:今天下午,原来一个部门的同事找过来,说有个即将上线的环境偶尔会出现 No more data to read from socket错误,版本是oracle 11.2.0.1,如下: 经查,这个问题原因比较多,有oracle自己的bug,有可能配置的问题,也有可能代码上的问题。主要有如下: 1、jd
阅读全文
浙公网安备 33010602011771号