Fork me on GitHub

Uva 550 - Multiplying by Rotation

  Multiplying by Rotation 

Warning: Not all numbers in this problem are decimal numbers!

 


Multiplication of natural numbers in general is a cumbersome operation. In some cases however the product can be obtained by moving the last digit to the front.

 


Example: 179487 * 4 = 717948

 


Of course this property depends on the numbersystem you use, in the above example we used the decimal representation. In base 9 we have a shorter example:

 


17 * 4 = 71 (base 9)

 


as (9 * 1 + 7) * 4 = 7 * 9 + 1

 

Input 

The input for your program is a textfile. Each line consists of three numbers separated by a space: the base of the number system, the least significant digit of the first factor, and the second factor. This second factor is one digit only hence less than the base. The input file ends with the standard end-of-file marker.

 

Output 

Your program determines for each input line the number of digits of the smallest first factor with the rotamultproperty. The output-file is also a textfile. Each line contains the answer for the corresponding input line.

 

Sample Input 

10 7 4
9 7 4
17 14 12

 

Sample Output 

6
2
4

 

 


Miguel A. Revilla 
1998-03-10
 
#include<stdio.h>
#include<string.h>

int main()
{
    int i, cnt, base, last, n, front;
    int carry, exce, flag, temp;
    while(scanf("%d%d%d", &base, &last, &n) != EOF)
    {
        
        for(flag=cnt=carry=0,front=last; !(flag == 1 && carry == 0 && front == last); cnt++)
        {
            temp = front*n + carry;
            carry = temp/base, front = temp%base;
            flag = 1;
        }
        printf("%d\n", cnt);
    }
    
    return 0;
}

解题思路:

题目的意思是根据在有这种特殊的计算情况的前提下,给你进制的基数、第一个因子的最后一位数的值、第二个因子,要求你计算出第一个因子的长度,这种题目模拟一下就行了

1y

posted @ 2013-03-08 19:18  Gifur  阅读(549)  评论(0编辑  收藏  举报
TOP