hdoj_1711Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7619    Accepted Submission(s): 3469


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1
#include<iostream>
using namespace std;
#pragma warning(disable : 4996)
const int MAXN = 10005;
int Next[MAXN];
int text[1000005] = {0};
int pat[MAXN] = {0};
int n, m;

void get_next()
{
	int i = 0, j = -1;
	Next[0] = -1;
	while(i < m)
	{
		if(j == -1 || pat[i] == pat[j])
		{
			i++;
			j++;
			Next[i] = j;
		}
		else
		{
			j = Next[j];
		}
	}
}
int kmp()
{
	get_next();
	int i = 0, j = 0;
	while(i < n && j < m)
	{
		if(j == -1 || text[i] == pat[j])
		{
			i++;
			j++;
		}
		else
		{
			j = Next[j];
		}
	}
	if(j >= m)
	{
		return i - m + 1;
	}
	else
	{
		return -1;
	}
}

int main()
{
	freopen("in.txt", "r", stdin);
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d %d", &n, &m);
		for(int i = 0; i < n; i++)
		{
			scanf("%d", &text[i]);
		}
		for(int i = 0; i < m; i++)
		{
			scanf("%d", &pat[i]);
		}
		printf("%d\n", kmp());
	}
	return 0;
}



posted @ 2013-05-07 15:06  N3verL4nd  阅读(109)  评论(0编辑  收藏  举报