POJ-3461-Oulipo KMP

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 38603   Accepted: 15551

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A','B', 'C', …, 'Z'} and two finite strings over that alphabet, a wordW and a text T, count the number of occurrences of W inT. All the consecutive characters of W must exactly match consecutive characters ofT. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B','C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the stringW).
  • One line with the text T, a string over {'A', 'B','C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the wordW in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0


代码:

#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<cstdio>
using namespace std;
int Next[10005];
char t[1000005],p[10005];
int tlen,plen;
void getNext() {
    int j,k;
    j=0;
    k=-1;
    Next[0]=-1;
    while(j<plen) {
        if(k==-1||p[j]==p[k]) {
            j++;
            k++;
            Next[j]=k;
        } else {
            k=Next[k];
        }
    }
}
int KMP_Index() {
    int i=0,j=0;
    getNext();
    while(i<tlen&&j<plen) {
        if(j==-1||t[i]==p[j]) {
            i++;
            j++;
        } else {
            j=Next[j];
        }
    }
    if(j==plen)
        return i-j;
    return -1;
}
int KMP_Count() {
    int ans=0;
    int i,j=0;
    if(tlen==1&&plen==1) {
        if(t[0]==p[0])
            return 1;
        return 0;
    }
    getNext();
    for(i=0; i<tlen; i++) {
        while(j>0&&t[i]!=p[j])
            j=Next[j];
        if(t[i]==p[j])
            j++;
        if(j==plen) {
            ans++;
            j=Next[j];
        }
    }
    return ans;
}
int main() {
    int tt;
    scanf("%d",&tt);
    while(tt--) {
        scanf("%s",p);
        scanf("%s",t);
        tlen=strlen(t);
        plen=strlen(p);
        //printf("%d\n",KMP_Index());
        printf("%d\n",KMP_Count());
    }
    return 0;
}


posted @ 2017-11-03 01:43  lemonsbiscuit  阅读(88)  评论(0编辑  收藏  举报