Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

Sample Output
4 2 0
 

题意:给两个字符串,求这两个字符串的最长公共子序列的长度。

序列特点:最长公共子序列中的字符出现的顺序和两个母串中出现的顺序是一样的。而最长公共子串则要求的更严格一点,子串中字符出现的顺序和母串中出现的顺序都必须是连续的;

代码如下:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<ctype.h>
#include<algorithm>
#define N 1010
using namespace std;

int dp[1010][1010];
int main ()
{
    int n,m,i,j;
    int len1,len2;
    char a[N],b[N];
    a[0]='-';
    b[0]='-';
    while(~scanf("%s %s",a+1,b+1)){//使得存的字符串从字符串的地二位开始存;
        len1=strlen(a);
        len2=strlen(b);
        for(i=1;i<max(len1,len2);i++){//初始化
            dp[i][0]=dp[0][i]=0;
        }
        for(i=1;i<len1;i++){
            for(j=1;j<len2;j++){
                if(a[i]==b[j]){
                    dp[i][j]=dp[i-1][j-1]+1;
                }else {
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        /*for(i=0;i<len1;i++){
            for(j=0;j<len2;j++){
                printf("%d ",dp[i][j]);
            }
            printf("\n");
        }*/
        printf("%d\n",dp[len1-1][len2-1]);
    }
    return 0;
}


 posted on 2017-04-20 15:30  拖延症重症患者~  阅读(91)  评论(0编辑  收藏  举报