ZOJ 1203 Swordfish

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=203

Swordfish

Time Limit: 2 Seconds      Memory Limit: 65536 KB

There exists a world within our world
A world beneath what we call cyberspace.
A world protected by firewalls,
passwords and the most advanced
security systems.
In this world we hide
our deepest secrets,
our most incriminating information,
and of course, a shole lot of money.
This is the world of Swordfish.

  We all remember that in the movie Swordfish, Gabriel broke into the World Bank Investors Group in West Los Angeles, to rob $9.5 billion. And he needed Stanley, the best hacker in the world, to help him break into the password protecting the bank system. Stanley's lovely daughter Holly was seized by Gabriel, so he had to work for him. But at the last moment, Stanley made some little trick in his hacker mission: he injected a trojan horse in the bank system, so the money would jump from one account to another account every 60 seconds, and would continue jumping in the next 10 years. Only Stanley knew when and where to get the money. If Gabriel killed Stanley, he would never get a single dollar. Stanley wanted Gabriel to release all these hostages and he would help him to find the money back.
  You who has watched the movie know that Gabriel at last got the money by threatening to hang Ginger to death. Why not Gabriel go get the money himself? Because these money keep jumping, and these accounts are scattered in different cities. In order to gather up these money Gabriel would need to build money transfering tunnels to connect all these cities. Surely it will be really expensive to construct such a transfering tunnel, so Gabriel wants to find out the minimal total length of the tunnel required to connect all these cites. Now he asks you to write a computer program to find out the minimal length. Since Gabriel will get caught at the end of it anyway, so you can go ahead and write the program without feeling guilty about helping a criminal.

Input:
The input contains several test cases. Each test case begins with a line contains only one integer N (0 <= N <=100), which indicates the number of cities you have to connect. The next N lines each contains two real numbers X and Y(-10000 <= X,Y <= 10000), which are the citie's Cartesian coordinates (to make the problem simple, we can assume that we live in a flat world). The input is terminated by a case with N=0 and you must not print any output for this case.

Output:
You need to help Gabriel calculate the minimal length of tunnel needed to connect all these cites. You can saftly assume that such a tunnel can be built directly from one city to another. For each of the input cases, the output shall consist of two lines: the first line contains "Case #n:", where n is the case number (starting from 1); and the next line contains "The minimal distance is: d", where d is the minimal distance, rounded to 2 decimal places. Output a blank line between two test cases.

Sample Input:

5
0 0
0 1
1 1
1 0
0.5 0.5
0


Sample Output:

Case #1:
The minimal distance is: 2.83

题意:给定平面上N个城市的位置,计算连接这N个城市所需线路长度总和的最小值

思路:裸的最小生成树

AC代码:

#include <bits/stdc++.h>
using namespace std;
const int N=10010;
struct node{
    double x,y,d;
}q[N];
double a[N],b[N];
int n,k;
int pre[N];
bool cmp(node a,node b){
    return a.d<b.d;
}
double f(int i,int j){
    return (a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j]);
}
void init(){
    for(int i=1;i<=n;i++){
        pre[i]=i;
    }
}

int Find(int x){
    if(x!=pre[x]) pre[x]=Find(pre[x]);
    return pre[x];
}
int join(int x,int y){
    int tx=Find(x);
    int ty=Find(y);
    if(tx!=ty){
        pre[ty]=tx;
    }
}
double Kru(){
    double ans=0.0;
    sort(q,q+k,cmp);
    for(int i=0;i<k;i++){
        if(Find(q[i].x)!=Find(q[i].y)){
            join(q[i].x,q[i].y);
            ans+=q[i].d;
        }
    }
    return ans;
}
int main(){
    int iCase=1;
    while(scanf("%d",&n)&&n){
        k=0;
        init();
        if(iCase!=1) printf("\n");
        for(int i=1;i<=n;i++){

            scanf("%lf%lf",&a[i],&b[i]);
            for(int j=1;j<i;j++){
                q[k].x=(double)i;
                q[k].y=(double)j;
                q[k++].d=sqrt(f(i,j));
            }
        }

        double ans=Kru();
        printf("Case #%d:\n",iCase++);
        printf("The minimal distance is: %.2lf\n",ans);
    }
    return 0;
}

 

posted on 2018-09-20 17:19  坤sir  阅读(160)  评论(0编辑  收藏  举报

导航