A hard puzzle ACM HDU1097

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13437    Accepted Submission(s): 4677


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
7 66 8 800
 

Sample Output
9 6
 

Author
eddy
 

Recommend
JGShining
 
#include<stdio.h>
int main()
{
int a,b;
int t;
int res;
while(scanf("%d%d",&a,&b)!=EOF)
{
t
=a%10;
res
=1;
while(b)
{
if(b%2!=0)
{
res
*=t;
res
%=10;
}
t
=t*t;
t
%=10;
b
/=2;
}
printf(
"%d\n",res);
}
}

posted on 2011-08-01 10:23  kuangbin  阅读(1598)  评论(4编辑  收藏  举报

导航

JAVASCRIPT: