Bi-shoe and Phi-shoe 欧拉函数 素数

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

Hint

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<set>
#include<fstream>
#include<memory>
#include<list>
#include<string>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
#define MAXN  1000030
#define N 10009
#define INF 1000000009
/*
欧拉函数
打表
*/
LL T, n, a[N];
bool notprime[MAXN];
vector<LL> prime;
void Init()
{
    memset(notprime, sizeof(notprime), false);
    notprime[1] = true;
    //prime.resize(N);
    for (LL i = 2; i < MAXN; i++)
    {
        if (!notprime[i])
        {
            prime.push_back(i);
            for (int j = i + i; j < MAXN; j+=i)
            {
                notprime[j] = true;
            }
        }
    }
}
LL solve(LL x)
{
    return *upper_bound(prime.begin(), prime.end(), x);
}
int main()
{
    Init();
    scanf("%lld", &T);
    for(LL cas = 1;cas<=T;cas++)
    {
        scanf("%lld", &n);
        LL sum = 0;
        for (LL i = 0; i < n; i++)
        {
            scanf("%lld", &a[i]);
            sum += solve(a[i]);
        }
        printf("Case %lld: %lld Xukha\n",cas,sum);
    }
    return 0;
}

 

posted @ 2017-05-05 15:44  joeylee97  阅读(201)  评论(0编辑  收藏  举报