UVA 10391 Compound Words

 

Problem E: Compound Words

 

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

 

Sample Output

alien
newborn

题意:输入一些单词。要输出其中,可以由两个单词拼接组合成的单词。。

思路:题中数据有12W,,直接暴力时间复杂度为肯定会超时。。需要高效的方法

我是用map,输入的时候把每个单词标记成1。然后每个单词找过去。每个单词从每个字母位置分成2个单词。如果2个单词均是有标记成1的,代表这个单词可以被组合,就输出来

这样做的话。时间复杂度接近于O(n)。。。A之。。

 

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <map>
using namespace std;

char ci[122222][25];
int len;
map<string, int> adj;
int main()
{
    int n = 0;
    while (gets(ci[n]) != NULL)
    {
	adj[ci[n]] = 1;
	n ++;
    }	
    for (int i = 0; i < n ; i ++)
    {
	len = strlen(ci[i]);
	for (int j = 1; j < len - 1; j ++)
	{
	    char a[25], b[25];
	    for (int k = 0; k < j; k ++)
		a[k] = ci[i][k];
	    a[j] = '\0';
	    for (int k = j; k < len; k ++)
		b[k - j] = ci[i][k];
	    b[len - j] = '\0';
	    if (adj[a] == 1 && adj[b] == 1)
	    {
		printf("%s\n", ci[i]);
		break;
	    }
	}
    }
    return 0;
}


 


 

posted @ 2013-07-31 20:10  坚固66  阅读(230)  评论(0编辑  收藏  举报