<html>

Agri-Net

Time Limit: 1000MS Memory limit: 10000K

题目描写叙述

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 

The distance between any two farms will not exceed 100,000.

输入

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

输出

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

演示样例输入

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

演示样例输出

28

#include <stdio.h>
#include <string.h>

int Map[110][110];
int eveco[110], vis[110];
int n,m;

int Prim(int n)
{
	int cost = 0;
	memset(vis, false, sizeof(vis));
	for(int i=1; i<=n; i++)
		eveco[i] = Map[1][i];
	vis[1] = true;
	for(int i=1; i<n; i++)
	{
		int m = 0x3f3f3f3f;
		int pos;
		for(int j=1; j<=n; j++)
			if(!vis[j] && eveco[j] < m)
				m = eveco[j], pos = j;
		if(m == 0x3f3f3f3f)
			break;
		cost += m;
		vis[pos] = true;
		for(int j=1; j<=n; j++)
			if(!vis[j] && eveco[j] > Map[pos][j])
				eveco[j] = Map[pos][j];
	}
	return cost;
}

int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1; i<=n; i++)
			for(int j=1; j<=n; j++)
				scanf("%d",&Map[i][j]);
		
		printf("%d\n",Prim(n));
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主同意不得转载。 举报
  • 本文已收录于下面专栏:

相关文章推荐

poj 1258 Agri-Net-----最小生成树 prim

Agri-Net Time Limit:1000MS </td

最小生成树( Highways + Agri-Net)

Highways Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other) Tot...

欢迎关注CSDN程序人生公众号

关注程序猿生活,汇聚开发轶事。

Agri-Net(kruskal)

H - Agri-Net Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:</st

POJ 1258 Agri-Net 【最小生成树入门题目】【prime模板】

Agri-Net Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 29613   Acce...

POJ 1258 Agri-Net(最小生成树)

POJ 1258 Agri-Net(最小生成树) http://poj.org/problem?

id=1258 <span style="color:

  • 微博
    微信
    QQ
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多仅仅同意输入30个字)

posted @ 2017-08-20 15:47  jhcelue  阅读(134)  评论(0编辑  收藏  举报