Sightseeing tour
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9709   Accepted: 4089

Description

The city executive board in Lund wants to construct a sightseeing tour by bus in Lund, so that tourists can see every corner of the beautiful city. They want to construct the tour so that every street in the city is visited exactly once. The bus should also start and end at the same junction. As in any city, the streets are either one-way or two-way, traffic rules that must be obeyed by the tour bus. Help the executive board and determine if it's possible to construct a sightseeing tour under these constraints.

Input

On the first line of the input is a single positive integer n, telling the number of test scenarios to follow. Each scenario begins with a line containing two positive integers m and s, 1 <= m <= 200,1 <= s <= 1000 being the number of junctions and streets, respectively. The following s lines contain the streets. Each street is described with three integers, xi, yi, and di, 1 <= xi,yi <= m, 0 <= di <= 1, where xi and yi are the junctions connected by a street. If di=1, then the street is a one-way street (going from xi to yi), otherwise it's a two-way street. You may assume that there exists a junction from where all other junctions can be reached.

Output

For each scenario, output one line containing the text "possible" or "impossible", whether or not it's possible to construct a sightseeing tour.

Sample Input

4
5 8
2 1 0
1 3 0
4 1 1
1 5 0
5 4 1
3 4 0
4 2 1
2 2 0
4 4
1 2 1
2 3 0
3 4 0
1 4 1
3 3
1 2 0
2 3 0
3 2 0
3 4
1 2 0
2 3 1
1 2 0
3 2 0

Sample Output

possible
impossible
impossible
possible

Source

——————————————————————————————
题目的意思是给出一张图,有有向边和无向边,稳是否存在欧拉回路
思路:混合图的欧拉回路判定,先把无向边随意值一个方向,判断每个点入度出度之差,若为奇数不可能。否则进行进一步判定。你把无向边安指定的方向建图,算出每个点的入度出度,弱入度大于出度则吧源点和它相连,反之连汇点,判断是否满流
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
#define MAXN 500

struct node
{
    int u, v, next, cap;
} edge[MAXN*MAXN];
int nt[MAXN], s[MAXN], d[MAXN], visit[MAXN];
int cnt;
int a[2005];
int b[2005];
struct ed
{
    int u,v,f;
} e[2005];

void init()
{
    cnt = 0;
    memset(s, -1, sizeof(s));
}

void add(int u, int v, int c)
{
    edge[cnt].u = u;
    edge[cnt].v = v;
    edge[cnt].cap = c;
    edge[cnt].next = s[u];
    s[u] = cnt++;
    edge[cnt].u = v;
    edge[cnt].v = u;
    edge[cnt].cap = 0;
    edge[cnt].next = s[v];
    s[v] = cnt++;
}

bool BFS(int ss, int ee)
{
    memset(d, 0, sizeof d);
    d[ss] = 1;
    queue<int>q;
    q.push(ss);
    while (!q.empty())
    {
        int pre = q.front();
        q.pop();
        for (int i = s[pre]; ~i; i = edge[i].next)
        {
            int v = edge[i].v;
            if (edge[i].cap > 0 && !d[v])
            {
                d[v] = d[pre] + 1;
                q.push(v);
            }
        }
    }
    return d[ee];
}

int DFS(int x, int exp, int ee)
{
    if (x == ee||!exp) return exp;
    int temp,flow=0;
    for (int i = nt[x]; ~i ; i = edge[i].next, nt[x] = i)
    {
        int v = edge[i].v;
        if (d[v] == d[x] + 1&&(temp = (DFS(v, min(exp, edge[i].cap), ee))) > 0)
        {
            edge[i].cap -= temp;
            edge[i ^ 1].cap += temp;
            flow += temp;
            exp -= temp;
            if (!exp) break;
        }
    }
    if (!flow) d[x] = 0;
    return flow;
}

int Dinic_flow(int ss, int ee)
{
    int ans = 0;
    while (BFS(ss, ee))
    {
        for (int i = 0; i <= ee; i++) nt[i] = s[i];
        ans+= DFS(ss, INF, ee);
    }
    return ans;
}

int main()
{
    int T;
    int n,m;
    for(scanf("%d",&T); T--;)
    {
        init();
        scanf("%d%d",&n,&m);
        memset(a,0,sizeof a);
        memset(b,0,sizeof b);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].f);
            a[e[i].u]++,b[e[i].v]++;
        }
        int flag=0;
        for(int i=1; i<=n; i++)
            if(((int)fabs(a[i]-b[i]))%2==1)
            {
                flag=1;
                break;
            }
        if(!flag)
        {
            memset(a,0,sizeof a);
            memset(b,0,sizeof b);
            for(int i=0; i<m; i++)
            {
                if(e[i].f==0)
                    add(e[i].u,e[i].v,1);

                    a[e[i].u]++,b[e[i].v]++;
            }
            int ct=0;
            for(int i=1; i<=n; i++)
                if(a[i]<b[i])
                    add(i,n+1,(b[i]-a[i])/2);
                else if(a[i]>b[i])
                    add(0,i,(a[i]-b[i])/2),ct+=(a[i]-b[i])/2;
            if(ct!=Dinic_flow(0,n+1))
            flag=1;
        }
        if(flag)
            printf("impossible\n");
        else
            printf("possible\n");
    }
    return 0;
}