竹山一叶

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::
  390 随笔 :: 0 文章 :: 0 评论 :: 0 引用

 问题如下图所示: 

 

解决:

 修改 gradle-wrapper.properties里的gradle的版本,与之前没有报错的gradle版本一致。就可以了

    比如我报这个错的时候 :

distributionUrl=https\://services.gradle.org/distributions/gradle-4.4-all.zip

    修改后:

distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-all.zip

最后 重新编译一下 解决!

 

问题分析:出现该问题的原因是由于更新Gradle Version库下载不完整导致出现上面的问题。

解决方法:

    1)重新下载gradle,浏览器输入下载地址 https://services.gradle.org/distributions/gradle-4.4-all.zip (下载其他版本只需要更改其中的版本号)

    2)进入目录C:\Users\JF\.gradle\wrapper\dists\gradle-4.4-all\9br9xq1tocpiv8o6njlyu5op1,使用下载的gradle-4.4-all.zip进行替换

    3)打开Android Studio,在Terminal里输入:gradle -v,如果没有下载就会自动下载,如果已经下载则会自动解压

 

 

 

posted on 2018-05-09 11:49 竹山一叶 阅读(...) 评论(...) 编辑 收藏