HDU_1398_母函数

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11143    Accepted Submission(s): 7634


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

 

Sample Input
2
10
30
0
 

 

Sample Output
1
4
27
 
题意:有17种钱币S[i]=i*i,给一个小于等于300的数,问有多少中组成这个数的方法。
dfs超时,应该是自己写得不好,然后想到母函数,自己写的也超时,非常费解,看了别人的代码,感觉时间上出入很小,感觉是有点卡时间。
对母函数的理解又加深了一点。
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

int S[18];
int c1[305];
void cal(int n)
{

    int c2[n+1];
    for(int i=0; i<=n; i++)
    {
        c1[i]=1;
        c2[i]=0;
    }
    for(int i=2; i<=17; i++)
    {
        for(int j=0; j<=n; j++)
            for(int k=0; k+j<=n; k+=i*i)
                c2[j+k]+=c1[j];
        for(int j=0; j<=n; j++)
        {
            c1[j]=c2[j];
            c2[j]=0;
        }
    }
    //return c1[n];
}

int main()
{
    int n;
    //for(int i=1;i<=17;i++)
     //   S[i]=i*i;
    cal(302);
    while(scanf("%d",&n)!=EOF&&n)
    {
        printf("%d\n",c1[n]);
    }
    return 0;
}

 

posted on 2016-07-29 11:22  JASONlee3  阅读(179)  评论(0编辑  收藏  举报

导航