HDU Wooden Sticks

Wooden Sticks

http://acm.hdu.edu.cn/game/entry/problem/show.php?chapterid=1&sectionid=3&problemid=16

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1480    Accepted Submission(s): 595
 
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute. (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 
Output
The output should contain the minimum setup time in minutes, one per line.
 
Sample Input
3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1
 
Sample Output
2
1
3
 
 
Source
Asia 2001, Taejon (South Korea)

 

 

 

#include<stdio.h>
#include<stdlib.h>

struct node{
    int len,weight;
    int tag;
}a[5005];

int cmp(const void *a,const void *b){
    node c=*(node *)a;
    node d=*(node *)b;
    if(c.len==d.len)
        return c.weight-d.weight;
    return c.len-d.len;
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        int i;
        for(i=0;i<n;i++){
            scanf("%d%d",&a[i].len,&a[i].weight);
            a[i].tag=0;
        }
        qsort(a,n,sizeof(a[0]),cmp);
        int ans=0,flag;
        int j,cnt=0;
        a[0].tag=1;
        while(cnt<n){
            ++ans;
            for(i=cnt+1,j=cnt,flag=1;i<n;i++){
                if(a[i].tag)
                    continue;
                if(a[j].len<=a[i].len && a[j].weight<=a[i].weight){
                    j=i;
                    a[i].tag=1;
                }else{
                    if(flag){
                        flag=0;
                        cnt=i;
                    }
                }
            }
            if(flag)
                break;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

 

 

posted @ 2013-01-02 16:13  Jack Ge  阅读(946)  评论(0编辑  收藏  举报