工具异常问题解决

Eclipse中SVN插件常遇到的异常:

Subclipse talks to Subversion via a Java API that requires access to native libraries.
Those libraries where either not found or an incompatible version was loaded. The
errors are displayed below.

Information on getting a proper version installed and visible to Eclipse is avaiable here:

http://subclipse.tigris.org/wiki/JavaHL

Errors:
Failed to load JavaHL Library.
These are the errors that were encountered:
no msvcp100 in java.library.path
D:\Program Files\eclipses\configuration\org.eclipse.osgi\bundles\767\1\.cp\libsvnjavahl-1.dll: Can't find dependent libraries
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path = D:\Program Files\eclipses;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;D:/Program Files/Java/jdk1.7.0_09/bin/../jre/bin/server;D:/Program Files/Java/jdk1.7.0_09/bin/../jre/bin;D:/Program Files/Java/jdk1.7.0_09/bin/../jre/lib/amd64;D:\Program Files\Java\jdk1.7.0_09\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;D:\Program Files\apache-maven-3.0.3\bin;D:\Program Files\TortoiseSVN\bin;D:\Program Files\SSH;D:\Program Files\eclipses;;.

 

org.apache.subversion.javahl.ClientException:svn:E155021:This client is too old to work with the working copy at 'E:\SVN\java'.

解决方案:Window -> Preferences -> Team -> SVN,将SVN接口的Client修改为SVNKit(Pure JAVA) SVNKit v1.7.9.XXXX选项

如图:

 

 

 

 

posted @ 2014-06-25 10:49  雨之殇  阅读(18750)  评论(1编辑  收藏