poj 2752 Seek the Name, Seek the Fame KMP

Language:
Seek the Name, Seek the Fame
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 12466   Accepted: 6139

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source


题意:给一个字符串str,求出既是前缀又是后缀的所有长度。这一题是KMP的next数组的应用。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 400010
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int next[maxn],ans[maxn];
char str[maxn];

void get_next()
{
    int len=strlen(str);
    int i=0,j=-1;
    next[0]=-1;
    while (i<len)
    {
        if (j==-1||str[i]==str[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
    ans[0]=len;
    int t=1;
    j=len;
    while (next[j]>0)  //递推出所有的长度并记录在ans数组里
    {
        ans[t]=next[j];
        t++;
        j=next[j];
    }
    for (int i=t-1;i>0;i--)
        printf("%d ",ans[i]);
    printf("%d\n",ans[0]);
}

int main()
{
    while (scanf("%s",str)!=EOF)
        get_next();
    return 0;
}
/*
ababcababababcabab
aaaaa
*/


posted @ 2014-10-19 11:00  浪子小黄人  阅读(144)  评论(0编辑  收藏  举报