Oulipo (poj 3461&&hdu 1686) KMP

Language:
Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 24557   Accepted: 9857

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

得多做几道KMP啊~~

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int nextval[11000];
char str[1000010],pstr[11000];
int T;

void get_nextval()
{
    int plen=strlen(pstr);
    int i=0;
    nextval[i]=-1;
    int j=-1;
    while (i<plen)
    {
        if (j==-1||pstr[i]==pstr[j])
        {
            i++;
            j++;
            if (pstr[i]!=pstr[j])
                nextval[i]=j;
            else
                nextval[i]=nextval[j];
        }
        else
            j=nextval[j];
    }
}

int kmp_search()
{
    int ans=0;
    int plen=strlen(pstr);
    int slen=strlen(str);
    int i=0;
    int j=0;
    while (i<slen)
    {
        if (j==-1||pstr[j]==str[i])
        {
            i++;
            j++;
        }
        else
            j=nextval[j];
        if (j==plen)
        {
            ans++;
            j=nextval[j];  //hdu2087就这里稍微不同,注意区别
        }
    }
    return ans;
}

int main()
{
    scanf("%d",&T);
    while (T--)
    {
        scanf("%s%s",pstr,str);
        get_nextval();
        printf("%d\n",kmp_search());
    }
    return 0;
}
/*
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
*/
/*
3
AZA
AZAZAZA
BAPC
BAPC
VERDI
AVERDXIVYERDIAN
*/


posted @ 2014-10-19 11:20  浪子小黄人  阅读(181)  评论(0编辑  收藏  举报