I - Little Boxes HDU - 6225

Here N (N ≥ 3) rabbits are playing by the river. They are playing on a number line, each occupying a different integer. In a single move, one of the outer rabbits jumps into a space between any other two. At no point may two rabbits occupy the same position.
Help them play as long as possible
Input
The input has several test cases. The first line of input contains an integer t (1 ≤ t ≤ 500) indicating the number of test cases.
For each case the first line contains the integer N (3 ≤ N ≤ 500) described as above. The second line contains n integers a1 < a2 < a3 < … < aN which are the initial positions of the rabbits. For each rabbit, its initial position
ai satisfies 1 ≤ ai ≤ 10000.
Output
For each case, output the largest number of moves the rabbits can make.
Sample Input
5
3
3 4 6
3
2 3 5
3
3 5 9
4
1 2 3 4
4
1 2 4 5
Sample Output
1
1
3
0
1

  • 题意:单纯四个数相加,求和

  • 解题思路©:这个可以用java大数.这里介绍一个c++的写法.用unsigned long long 长度为264次方,题目数据最大262,因此,只用四个全为262式会超范围,特判一下即可.

#include<bits/stdc++.h>
using namespace std;
const int MAX = 80;
int x[MAX];
int y[MAX];
int ans[MAX];
int main()
{
	int t;
	unsigned long long a, b, c, d, temp1, temp2;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%lld %lld %lld %lld", &a, &b, &c, &d);
		if(a ==  4611686018427387904 && b == 4611686018427387904 && c == 4611686018427387904 && d == 4611686018427387904)
			cout<<"18446744073709551616"<<endl;
		else
			cout<<b+a+c+d<<endl;
	}
	return 0;

}
posted @ 2018-10-13 11:14  i-Curve  阅读(172)  评论(0编辑  收藏  举报