B - Big Event in HDU

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002. 
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds). 

InputInput contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different. 
A test case starting with a negative integer terminates input and this test case is not to be processed. 
OutputFor each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output

20 10
40 40

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

struct De
{
    int a,k;
};
De ch[50];


int main()
{
    int n,sum;
    while(scanf("%d",&n) && n>=0)
    {
        sum=0;
        for(int i=0;i<n;i++)
            scanf("%d %d",&ch[i].a,&ch[i].k),sum+=ch[i].a*ch[i].k;
        int fb[500000];
        memset(fb,0,sizeof(fb));
        for(int i=0; i<n; i++)
            for(int h=0;h<ch[i].k;h++)
                for(int j=sum/2;j>=ch[i].a;j--)
                    fb[j]=max(fb[j],fb[j-ch[i].a]+ch[i].a);
        printf("%d %d\n",sum-fb[sum/2],fb[sum/2]);
    }
    return 0;
}
View Code

 

posted on 2018-08-13 19:22  huas_psw  阅读(145)  评论(0编辑  收藏  举报