HDU2689:Sort it(冒泡排序)

Sort it

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2200    Accepted Submission(s): 1580


Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
 

Output
For each case, output the minimum times need to sort it in ascending order on a single line.
 

Sample Input
3
1 2 3
4 
4 3 2 1 
 

Sample Output
0
6
#include<stdio.h>
int paixu(int *a,int n)
{
    int i,j,temp,count=0;
    for(i=0;i<n-1;i++)
    for(j=0;j<n-1-i;j++)
    {
        if(a[j]>a[j+1])
        {
            temp=a[j];
            a[j]=a[j+1];
            a[j+1]=temp;
            count++;
        }
        
    }
    return count;
} 
int main()
{
    int i,test,a[1005];
    while(scanf("%d",&test)!=EOF)
    {
        for(i=0;i<test;i++)
        scanf("%d",&a[i]);
        //paixu(a,test);
        printf("%d\n",paixu(a,test));
    }
    return 0;
}

 

posted @ 2014-04-19 11:57  盒子先生★  阅读(182)  评论(0编辑  收藏  举报