TensorFlow 2 文档 TensorFlow 2 教程 Python 简明教程 Go 语言简明教程 Go 面试题 Go 高性能编程

Winter-1-B Sum 解题报告及测试数据

Time Limit:500MS     

Memory Limit:32768KB

Description

​Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

​For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1

100

Sample Output

1

5050 

以下是代码:

#include <cstdio>
using namespace std;
int main(){
    int n,sum;
    while(scanf("%d",&n)!=EOF){
        sum=0;
        for(int i=1;i<=n;i++)sum+=i;
        printf("%d\n\n",sum);
    }
}

  

posted @ 2015-02-23 15:49  呆尐兔兔  阅读(228)  评论(0编辑  收藏  举报