hdu 1754 I hate it

.

.

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 119855    Accepted Submission(s): 44356


Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

 

Sample Input
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

 

Sample Output
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin
 

 

Author
linle
 

 

 

#include <iostream>
#include <algorithm>
#include <cmath>
#include <stdio.h>
#include <cstring>
#include <string>
#include <cstdlib>
#include <queue>
#include <stack>
#include <set>
#include <vector>
#include <map>
#include <list>
#include <iomanip>
#include <fstream>

using namespace std;
typedef long long ll;
const int maxn=200000;
int st[maxn<<2+7];
int a[maxn<<2+7];
int n;
//树状数组之精髓 lowbit
int lowbit(int x)
{
    return x&(-x);
}

void update(int k)
{
    while(k<=n)
    {
        st[k]=a[k];
        for(int i=1;i<lowbit(k);i<<=1)
            st[k]=max(st[k],st[k-i]);
        k+=lowbit(k);
    }
}

int query(int x,int y)
{
    int ans=0;
    while(y>=x)
    {
        ans=max(ans,a[y]);
        --y;
        for(;y-lowbit(y)>=x;y-=lowbit(y))
            ans=max(ans,st[y]);
    }    
    return ans;
 } 
int main()
{
    int m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;++i)
        {
            int s;
            scanf("%d",&a[i]);
            update(i);
        }
        for(int i=1;i<=m;++i)
        {
            char op;
            scanf("%c",&op);
            if(op=='Q')
            {
                int x,y,ans;
                scanf("%d%d",&x,&y);
                ans=query(x,y);
                printf("%d\n",ans);
            }
            
            else if(op=='U')
            {
                int id,score;
                scanf("%d%d",&id,&score);
                a[id]=score;
                update(id);    
            } 
        }
        
    }
    return 0;
}

 

posted @ 2019-07-19 11:10  鹤花之歌  阅读(128)  评论(0编辑  收藏  举报