sgf87

zoj 1003 深度优先DFS

On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100. After the referee shouts "Let's go!" the two players, who each starts with a score of  "1", race to crash the balloons by their feet and, at the same time, multiply their scores by the numbers written on the balloons they crash.  After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his\her score, the product of the numbers on the balloons he\she's crashed.  The unofficial winner is the player who announced the highest score.

Inevitably, though, disputes arise, and so the official winner is not determined until the disputes are resolved.  The player who claims the lower score is entitled to challenge his\her opponent's score.  The player with the lower score is presumed to have told the truth, because if he\she were to lie about his\her score, he\she would surely come up with a bigger better lie.  The challenge is upheld if the player with the higher score has a score that cannot be achieved with balloons not crashed by the challenging player.  So, if the challenge is successful, the player claiming the lower score wins.

So, for example, if one player claims 343 points and the other claims 49, then clearly the first player is lying; the only way to score 343 is by crashing balloons labeled 7 and 49, and the only way to score 49 is by crashing a balloon labeled 49.  Since each of two scores requires crashing the balloon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims 81, it is possible for both to be telling the truth (e.g. one crashes balloons 2, 3 and 27, while the other crashes balloon 81), so the challenge would not be upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are telling the truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon is likely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculations that refereeing requires.  Hence the need for you, sober programmer, to provide a software solution.

Input

Pairs of unequal, positive numbers, with each pair on a single line, that are claimed scores from a game of crashing balloon.

Output

Numbers, one to a line, that are the winning scores, assuming that the player with the lower score always challenges the outcome.

Sample Input

343 49 3599 610 62 36 Sample Output
49 610 62 刚开始竟然想求出两个数所有乘积的组合,然后再找出必须有的再比较。。。。结果上网一看。。。有道理。。

网上的牛叉级,程序:
#include<stdio.h>
int a_sign,b_sign;
void bfs(int a,int b,int n)
{
if(b==1)
{
 if(a==1) a_sign=1;
 
 b_sign=1;
} 
if(n>100||(a_sign==1&&b_sign==1))
 return; 
if(b%n==0) bfs(a,b/n,n+1);
if(a%n==0) bfs(a/n,b,n+1);
bfs(a,b,n+1);
 
}

int main()
{
 int a,b,turn;
 while(scanf("%d %d",&a,&b)!=EOF)
 {
  if(a<b)
  {
   turn=a;
   a=b;
   b=turn; 
  }
  a_sign=b_sign=0;
  bfs(a,b,2);
  if(a_sign==1) printf("%d\n",a);
  else if(b_sign==1) printf("%d\n",b);
  else printf("%d\n",a);
  
 }
 return 0;
}
俺自己编的垃圾程序,现在依然是wa,好奇怪洒,所有的测试数据都通过,大家如果看出problem的话,请help 我modify一下:
#include <iostream>
#include <cmath>
using namespace std;
int Count=0;
int a[20]={1};
int C1,C2;
int flag=1;
bool isvalid(int m)
{
	for(int i=0;i<Count;i++)
		if(a[i]==m) return false;
	return true;
	
}
bool isPrime(int m)
{
	for(int i=2;i<=(int)sqrt((double)m);i++)
		if(m%i==0) return false;
	return true;
}
bool isOk(int m)
{
	if(m<100) return true;
	else
	{
		for(int i=2;i<=(int)sqrt((double)m);i++)
			if(m%i==0) {if(isOk(m/i)) return true;}
	}
	return false;
	
	
}
int solve(int i,int j)
{
	
	C1=i>j ? i:j;
	C2=i<j ? i:j;
	if(i<=100&&j<=100&&i!=j)
	{
		 if(!isPrime(i)) return 1;
		 if(!isPrime(j)) return 1;
		return 0;
	}
	for(int ix=2;ix<=(int)sqrt((double)i);ix++)  
	    if(i%ix==0&&((ix*ix)!=i)&&isvalid(ix)) 
			{
				a[Count++]=ix;
				a[Count++]=i/ix;
				i=i/ix;
				if(i>j) {if(solve(i,j)==1) return 1;}  
				else if(i<j) 
				{flag=-flag;if(solve(j,i)==1) return 1;}
			}
	
	return 0;

}
int main()
{

	int first,second;
	while(cin>>first>>second)
	{
		int min,max;
		Count=0;
		flag=1;
		if(first>second)
		{
			min=second;
			max=first;
		}
		else
		{
			min=first;
			max=second;
		}
		
		if(solve(max,min)==1) cout<<max<<endl;
		else if(C2>100) {
			if(flag==1&&!isPrime(C2))cout<<min<<endl;
			else if(flag==1&&isPrime(C2)) cout<<max<<endl;
			else if(flag==-1&&!isPrime(C2))cout<<max<<endl;
			else cout<<min<<endl;
		}
		else if(C1>100)
		{
			if(flag==-1&&!isPrime(C1)) cout<<min<<endl;
			else if(flag==1) cout<<min<<endl;
			else cout<<max<<endl;
		}
		else cout<<max<<endl;

	}
	return 0;
}

posted on 2010-04-27 20:54  sgf87  阅读(698)  评论(1编辑  收藏  举报

导航