hdu3466 Proud Merchants

Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?



 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
5

11

这题比較难想,想了非常久看别人题解做出来了。

这题关键是要理解怎么安排增加背包的物品的顺序,才干使后面增加的物品不影响前面已经增加的物品。我发现每一次进行循环的时候。都是从qi開始循环的,并且要用到qi-pi及其后的数。那么为了不使后面的物品影响前面的,要保证qi-pi是递增的,这样后面的就不会与前面冲突,能够细致想想:).

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
	int p,q,v,cha;
}a[600];
int f[6000];

bool cmp(node a,node b){
	return a.cha<b.cha;
}
int max(int a,int b){
	return a>b?

a:b; } int main() { int n,m,i,j; while(scanf("%d%d",&n,&m)!=EOF) { memset(a,0,sizeof(a)); memset(f,0,sizeof(f)); for(i=1;i<=n;i++){ scanf("%d%d%d",&a[i].p,&a[i].q,&a[i].v); a[i].cha=a[i].q-a[i].p; } sort(a+1,a+1+n,cmp); for(i=1;i<=n;i++){ for(j=m;j>=a[i].p;j--){ if(j>=a[i].q){ f[j]=max(f[j],f[j-a[i].p]+a[i].v); } } } printf("%d\n",f[m]); } return 0; }




posted on 2016-03-24 15:56  gcczhongduan  阅读(187)  评论(0编辑  收藏  举报