hdu 5325 Crazy Bobo 乱搞+搜索

Crazy Bobo


Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 218    Accepted Submission(s): 60


Problem Description
Bobo has a tree,whose vertices are conveniently labeled by 1,2,...,n.Each node has a weight wi. All the weights are distrinct.
A set with m nodes v1,v2,...,vm is a Bobo Set if:
- The subgraph of his tree induced by this set is connected.
- After we sort these nodes in set by their weights in ascending order,we get u1,u2,...,um,(that is,wui<wui+1 for i from 1 to m-1).For any node x in the path from ui to ui+1(excluding ui and ui+1),should satisfy wx<wui.
Your task is to find the maximum size of Bobo Set in a given tree.
 

Input
The input consists of several tests. For each tests:
The first line contains a integer n (1n500000). Then following a line contains n integers w1,w2,...,wn (1wi109,all the wi is distrinct).Each of the following n-1 lines contain 2 integers ai and bi,denoting an edge between vertices ai and bi (1ai,bin).
The sum of n is not bigger than 800000.
 

Output
For each test output one line contains a integer,denoting the maximum size of Bobo Set.
 

Sample Input
7 3 30 350 100 200 300 400 1 2 2 3 3 4 4 5 5 6 6 7
 

Sample Output
5
 

 


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5325

解题思路:反正我是智商余额不足。。。


AC代码:顺着题解思路DFS了一下= =

 1 #pragma comment(linker, "/STACK:1024000000,1024000000")
 2 #include <iostream>
 3 #include <cstdio>
 4 #include <cstring>
 5 #include <string>
 6 #include <cmath>
 7 #include <algorithm>
 8 #include <vector>
 9 #include <queue>
10 #include <set>
11 #include <map>
12 #include <stack>
13 #include <limits.h>
14 using namespace std;
15 typedef long long LL;
16 #define y1 y234
17 #define MAXN 500010 // 1e6
18 int n;
19 int a[MAXN];
20 vector<int> edge[MAXN];
21 int ans[MAXN];
22 void DFS(int u) {
23     ans[u] = 1;
24     int len = edge[u].size();
25     for(int i = 0; i < len; i++) {
26         int v = edge[u][i];
27         if(!ans[v]) DFS(v);
28         ans[u] += ans[v];
29     }
30 }
31 int main() {
32     while(~scanf("%d", &n)) {
33         memset(ans, 0sizeof ans);
34         for(int i = 1; i <= n; i++) {
35             scanf("%d", &a[i]);
36             edge[i].clear();
37         }
38         int u, v;
39         for(int i = 1; i < n; i++) {
40             scanf("%d%d", &u, &v);
41             if(a[u] < a[v]) edge[u].push_back(v);
42             else if(a[v] < a[u]) edge[v].push_back(u);
43         }
44         for(int i = 1; i <= n; i++) {
45             if(ans[i]) continue;
46             DFS(i);
47         }
48         int maxn = -1;
49         for(int i = 1; i <= n; i++) {
50             maxn = max(ans[i], maxn);
51         }
52         printf("%d\n", maxn);
53     }
54     return 0;

55 } 

posted @ 2015-07-28 20:02  gaoxiang36999  阅读(377)  评论(0编辑  收藏  举报