USACO Revamping Trails

USACO Revamping Trails

洛谷传送门

JDOJ传送门

Description

Farmer John dutifully checks on the cows every day. He traverses
some of the M (1 <= M <= 50,000) trails conveniently numbered 1..M
from pasture 1 all the way out to pasture N (a journey which is
always possible for trail maps given in the test data). The N (1
<= N <= 10,000) pastures conveniently numbered 1..N on Farmer John's
farm are currently connected by bidirectional dirt trails. Each
trail i connects pastures P1_i and P2_i (1 <= P1_i <= N; 1 <= P2_i
<= N) and requires T_i (1 <= T_i <= 1,000,000) units of time to
traverse.

He wants to revamp some of the trails on his farm to save time on
his long journey. Specifically, he will choose K (1 <= K <= 20)
trails to turn into highways, which will effectively reduce the
trail's traversal time to 0. Help FJ decide which trails to revamp
to minimize the resulting time of getting from pasture 1 to N.

Input

* Line 1: Three space-separated integers: N, M, and K

* Lines 2..M+1: Line i+1 describes trail i with three space-separated
integers: P1_i, P2_i, and T_i

Output

* Line 1: The length of the shortest path after revamping no more than
K edges

Sample Input

4 4 1 1 2 10 2 4 10 1 3 1 3 4 100

Sample Output

1


题解:

分层图最短路裸题。

关于分层图及其处理,请看:

浅谈分层图

代码:

#include<cstdio>
#include<vector>
#include<queue>
#include<cstring>
#define ll long long
using namespace std;
const int maxn=5e4+5;
int n,m,k;
int tot,head[maxn],nxt[maxn<<2],to[maxn<<2],val[maxn<<2];
void add(int x,int y,int z)
{
	to[++tot]=y;
	nxt[tot]=head[x];
	head[x]=tot;
	val[tot]=z;
}
bool vis[maxn][25];
ll dp[maxn][25];
priority_queue<pair<ll,ll>,vector<pair<ll,ll> >,greater<pair<ll,ll> > > q;
void dijkstra(int op)
{
	q.push(make_pair(0,1));
	while(!q.empty())
	{
		int x=q.top().second;
		q.pop();
		if(vis[x][op])
			continue;
		vis[x][op]=1;
		if(op)
			dp[x][op]=min(dp[x][op],dp[x][op-1]);
		for(int i=head[x];i;i=nxt[i])
		{
			int y=to[i];
			int w=val[i];
			if(!op)
			{
				if(!vis[y][op]&&dp[y][op]>dp[x][op]+w)
					dp[y][op]=dp[x][op]+w,q.push(make_pair(dp[y][op],y));
			}
			else
				if(!vis[y][op]&&dp[y][op]>min(dp[x][op]+w,dp[x][op-1]))
					dp[y][op]=min(dp[x][op]+w,dp[x][op-1]),q.push(make_pair(dp[y][op],y));
		}
	}
}
int main()
{
	// freopen("travel.in","r",stdin);
	// freopen("travel.out","w",stdout);
	scanf("%d%d%d",&n,&m,&k);
	for(int i=1;i<=m;i++)
	{
		int x,y,w;
		scanf("%d%d%d",&x,&y,&w);
		add(x,y,w);
		add(y,x,w);
	}
	memset(dp,127,sizeof(dp));
	dp[1][0]=0;
	for(int i=0;i<=k;i++)
		dijkstra(i);
	printf("%d\n",dp[n][k]);
	return 0;
}
posted @ 2020-12-02 15:32  Seaway-Fu  阅读(97)  评论(0编辑  收藏  举报