frank_wang

博客园 首页 新随笔 联系 订阅 管理

2005年5月19日 #

摘要: Skype与以往MSN等IM工具最大的不同在于基除了用户登录,其余工作基本不依赖中央服务器,Skype在穿透防火墙通讯时完全使用了Peer to Peer,而没用到中央服务器。上图中的小黑点是客户端,大黑点是超级节点(用于为其它客户端提供登录踏板及广播服务),灰色的点是Skype的登录服务器。用户下载安装完Skype后,Skype客户端会发送一段HTTP 1.1的请求到中央服务器,告诉它我装完了... 阅读全文
posted @ 2005-05-19 18:00 frank_wang 阅读(1204) 评论(0) 推荐(0)

摘要: Core SIP Documents RFC 2543 SIP: Session Initiation Protocol (obsolete) RFC 3261 SIP: Session Initiation Protocol SDP Related Documents RFC 2327 Session Description Protocol (SDP) RFC 3264 An Offer/A... 阅读全文
posted @ 2005-05-19 17:16 frank_wang 阅读(1455) 评论(0) 推荐(1)

摘要: 总部位于卢森堡的Skype公司在本周五宣布将推出一项名为SkypeIn的新服务。用户在订购了该服务后可使用手机接听电话,而不必支付昂贵的漫游费用。分析家认为这将威胁到移动运营商的漫游费收入。 据悉,用户在订购SkypeIn服务时需要先注册一个区号,然后会分到一个常用电话号码。这样即使用户到其他国家旅游,其他人仍可通过该常用号码与SkypeIn用户联络,而不必支付漫游费用。 据Skype公司称... 阅读全文
posted @ 2005-05-19 15:17 frank_wang 阅读(1006) 评论(0) 推荐(0)

摘要: 1)SIP用户代理向SIP代理服务器发送呼叫建立请求(INVITE); 2)SIP代理服务器向重定向服务器发送呼叫建立请求; 3)重定向服务器返回重定向消息; 4)SIP代理服务器向重定向服务器指定的SIP代理服务器发送呼叫建立请求; 5)被请求的SIP代理服务器使用非SIP协议例如域名查询或者LDAP等到定位服务器查询被叫位置; 6)定位服务器返回被叫位置(被叫SIP... 阅读全文
posted @ 2005-05-19 14:10 frank_wang 阅读(447) 评论(0) 推荐(0)

摘要: http://www.iptel.org/~sipsc/ 阅读全文
posted @ 2005-05-19 14:01 frank_wang 阅读(400) 评论(0) 推荐(0)