pat 1089

1089 Insert or Merge (25分)

 

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

 

题意:给定一个初始序列和这个序列的未完成排序序列b,要求判断所采用的排序方法是insertSort还是MergeSort,并且输出下一趟排序序列

思路:如果是插入排序,则前i个元素是有序的,而第i+1个元素小于第i个元素,并且从i+1个元素开始,后面的元素都和原始序列中元素的值一样,这样就可以判断是插入排序,输出下一趟序列只需要sort前i+1个元素即可。如果不满足上述条件,则说明是归并排序,将原始序列进行归并排序,每一趟比较所得排序序列和序列b是否一致,如果一致,再排一趟即所求结果。

代码如下:

#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
    int n;
    int a[100],b[100];
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&a[i]);
    }
    for(int i=0;i<n;i++){
        scanf("%d",&b[i]);
    }
    int i,j;
    for(i=0;i<n-1&&b[i]<=b[i+1];i++);
    for(j=i+1;a[j]==b[j]&&j<n;j++);
    if(j==n){
        printf("Insertion Sort\n");
        sort(a,a+i+2);
    }
    else{
        printf("Merge Sort\n");
        int flag=1;
        int k=1;
        while(flag){
            flag=0;
            for(i=0;i<n;i++){
                if(a[i]!=b[i]){
                    flag=1;
                }
            }
            k=k*2;
            for(i=0;i<n/k;i++){
                sort(a+i*k,a+(i+1)*k);
            }
            sort(a+n/k*k,a+n);
        }
    }
    for(j=0;j<n;j++){
        if(j!=0)
            printf(" %d",a[j]);
        else
            printf("%d",a[j]);
    } 
    
    return 0;
} 

 

posted @ 2020-07-24 10:02  9761滴  阅读(154)  评论(0编辑  收藏  举报