pat 1143

1143 Lowest Common Ancestor (30分)

 

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题意:给定一个二叉查找树,给出k次查询,每次查询要求查找给定的两个结点a,b的深度最深的公共祖先

思路:由于是二叉查找树,因此深度最大的公共祖先u是前序遍历序列上第一个满足u>=a&&a<=b或者u<=a&&u>=b的结点(好好体会下)。事实上,在a,b的所有公共祖先中,只有一个祖先u满足u的值在a,b之间,并且这个祖先就是 a,b的最大深度公共祖先。

代码如下:

#include<cstdio>
#include<vector>
#include<map>
using namespace std;
int main(){
    int m,n;
    map<int,bool> all;
    scanf("%d %d",&m,&n);
    vector<int> v;
    v.resize(n);
    for(int i=0;i<n;i++){
        scanf("%d",&v[i]);
        all[v[i]]=true;
    }
    int a,b;
    for(int i=0;i<m;i++){
        scanf("%d%d",&a,&b);
        int u;
        for(int j=0;j<v.size();j++){
            u=v[j];
            if((v[j]>=a&&v[j]<=b)||(v[j]>=b&&v[j]<=a)){
                break;
            }
        }
        if(all.count(a)==0&&all.count(b)==0)
            printf("ERROR: %d and %d are not found.\n",a,b);
        else if(all.count(a)==0)
            printf("ERROR: %d is not found.\n",a);
        else if(all.count(b)==0){
            printf("ERROR: %d is not found.\n",b);
        }
        else{
            if(u==a||u==b){
                printf("%d is an ancestor of %d.\n",u,u==a?b:a);
            }
            else
                printf("LCA of %d and %d is %d.\n",a,b,u);
        }
    } 
    return 0;
}

 

posted @ 2020-07-15 15:11  9761滴  阅读(152)  评论(0编辑  收藏  举报