python ----Linux上安装scrapy

在安装scrapy之前首先得确保你已经安装了python 以及pip

1,安装scrapy

pip install scrapy

如果报错:Could not find a version that satisfies the requirement Twisted>=13.1.0 (from Scrapy) (from versions: )
No matching distribution found for Twisted>=13.1.0 (from Scrapy)

原因是没有安装Twisted

2,安装Twisted。

wget https://pypi.python.org/packages/source/T/Twisted/Twisted-15.2.1.tar.bz2 --no-check-certificate
tar -xjvf Twisted-15.2.1.tar.bz2
cd Twisted-15.2.1
python setup.py install

  成功。

参考链接:http://blog.csdn.net/snowpay/article/details/64919647

 

posted @ 2017-11-09 10:33 那时的吻狠陶醉 阅读(...) 评论(...) 编辑 收藏