摘要:
通过 df -Th 查看 /var 目录使用了78%, 当登录到/var 目录,du -sh 实际使用112G 分析原因:应该是被删掉的文件 没被真正释放 解决办法: 1、lsof | grep deleted > deletedfile 查看有哪些未被释放的文件 2、排序看最大的未被释放的文件大小
阅读全文
posted @ 2019-02-14 16:03
fengjian1585
阅读(320)
推荐(0)
摘要:
kubernetes RBAC 需要了解 rules roles subjects rolebindings(role绑定)rules 是一组操作 verbs 、资源 、 api组。 如果只允许创建对象并检索他们的信息, 那么可是使用 verbs 的 get list create, 一个verbs
阅读全文
posted @ 2019-01-28 17:56
fengjian1585
阅读(698)
推荐(0)
摘要:
wappiness的值的大小对如何使用swap分区是有着很大的联系的。swappiness=0的时候表示最大限度使用物理内存,然后才是 swap空间,swappiness=100的时候表示积极的使用swap分区,并且把内存上的数据及时的搬运到swap空间里面。linux的基本默认设置为60,具体如下
阅读全文
posted @ 2019-01-28 14:57
fengjian1585
阅读(1972)
推荐(1)
摘要:
1、报错:: java.util.concurrent.ExecutionException: org.apache.kafka.common.errors.NotLeaderForPartitionException: This server is not the leader for that
阅读全文
posted @ 2019-01-28 09:37
fengjian1585
阅读(10546)
推荐(0)
摘要:
gitlab 使用流程 1. 开发人员写代码,开发产品。 2. 测试人员进行测试,如果发现bug, 填写 Issues - List - new issus 3. 开发人员修复bug, 从master 克隆代码,本地仓库建立分支,修改bug后,推送到gitlab分支。 4. 开发人员登录gitlab
阅读全文
posted @ 2019-01-24 13:17
fengjian1585
阅读(292)
推荐(0)
摘要:
为了统一化管理,需要把老版本的 gitlab 仓库 同步到新的gitlab上。 1. 新建组, 新gitlab 建立的group 与 原gitlab相同。2. 新建project 3. 选择导入
阅读全文
posted @ 2019-01-23 14:46
fengjian1585
阅读(917)
推荐(0)
posted @ 2019-01-14 15:53
fengjian1585
阅读(272)
推荐(0)
摘要:
安装 mongodb 不要使用mongodb 4.16版本 MONGO_INITDB_ROOT_USERNAME, MONGO_INITDB_ROOT_PASSWORD 创建一个新用户并设置该用户的密码。此用户在admin身份验证数据库中创建并具有角色root 如果不加设置 用户 密码参数,但是指定
阅读全文
posted @ 2019-01-11 17:23
fengjian1585
阅读(537)
推荐(0)
摘要:
time dd if=/dev/zero of=/root/test.db2 bs=200K count=10000 oflag=dsync
阅读全文
posted @ 2018-12-26 18:17
fengjian1585
阅读(189)
推荐(0)
摘要:
由于apache 官网的 docker image 是单点,要实现集群方式部署。 rocketmq 分为 nameserver 和 broker , 对于之间调用频繁的服务,会增加网络压力, 所以 考虑又网络通信 变成 进程间通信, 那么1个pod 中包含两个container。 关于rocketm
阅读全文
posted @ 2018-12-26 11:24
fengjian1585
阅读(5804)
推荐(0)
摘要:
rocketmq 并且编译下载 wget http://mirror.bit.edu.cn/apache/rocketmq/4.3.2/rocketmq-all-4.3.2-source-release.zip unzip rocketmq-all-4.3.2-source-release.zip
阅读全文
posted @ 2018-12-20 16:56
fengjian1585
阅读(1872)
推荐(0)
摘要:
Taint(污点)和 Toleration(容忍)可以作用于 node 和 pod
阅读全文
posted @ 2018-12-14 14:55
fengjian1585
阅读(830)
推荐(0)
摘要:
RocketMQ集群部署记录 #引用 https://cloud.tencent.com/developer/article/1147765 一、RocketMQ基础知识介绍 Apache RocketMQ是阿里开源的一款高性能、高吞吐量、队列模型的消息中间件的分布式消息中间件。RocketMQ具有
阅读全文
posted @ 2018-12-07 16:03
fengjian1585
阅读(470)
推荐(0)
摘要:
目前应用日志,tomcat日志 统一输出到 /data/logs/pod名字/ 目录下,并且/data/logs 目录挂载到cephfs上, tomcat 日志使用 cronolog进行日志切割 使用 cronjob 创建一个pod,在每天2点开始 清除日志。 successfulJobsHisto
阅读全文
posted @ 2018-12-03 17:03
fengjian1585
阅读(2615)
推荐(0)
摘要:
默认的pod 的/etc/hosts 无法自动数据 通过使用 k8s HostAliases ,可以想 pod /etc/hosts 注入主机名对应关系
阅读全文
posted @ 2018-12-03 14:41
fengjian1585
阅读(821)
推荐(0)
摘要:
# docker ps -adocker: error while loading shared libraries: libltdl.so.7: cannot open shared object file: No such file or directory 官方的jenkins镜像是基于Deb
阅读全文
posted @ 2018-11-16 18:08
fengjian1585
阅读(7989)
推荐(0)
摘要:
容器中JVM获取真实的CPU核数 基于 libsysconfcpus的方案,可以为各个版本的JDK提供一个通用的解决方案。 libsysconfcpus.so的原理是截获JVM获取CPU核数所用的系统调用sysconf(_SC_NPROCESSORS_CONF),改为读取环境变量LIBSYSCONF
阅读全文
posted @ 2018-11-06 16:40
fengjian1585
阅读(2115)
推荐(0)
摘要:
由于kafka、zk 集群已经部署在k8s中, kafka的服务名 kafka-hs, zk的服务名为:zk-cs ,对kafka进行监控,所以需要把监控部署到k8s中,选择使用kafka-eagle. 下载地址: http://download.smartloli.org/ kafka-eagle
阅读全文
posted @ 2018-10-31 15:39
fengjian1585
阅读(1583)
推荐(0)
摘要:
参考官网:https://kubernetes.io/docs/tasks/run-application/run-replicated-stateful-application/20-nproc.conf limits.conf senyint.conf Dockerfile docker bui
阅读全文
posted @ 2018-10-25 18:06
fengjian1585
阅读(994)
推荐(0)
摘要:
$ cat /etc/etcd/etcd.conf ETCD_DATA_DIR="/var/lib/etcd/default.etcd" #监听URL,用于与其他节点通讯 ETCD_LISTEN_PEER_URLS="https://10.207.33.148:2380" #告知客户端的URL, 也就是服务的URL ETCD_LISTEN_CLIENT_URLS="https://10.2...
阅读全文
posted @ 2018-10-19 16:32
fengjian1585
阅读(782)
推荐(0)
摘要:
gcr.mirrors.ustc.edu.cn
阅读全文
posted @ 2018-10-10 16:46
fengjian1585
阅读(327)
推荐(0)
摘要:
mysql5.7 安装 [root@VM_0_13_centos data]# rpm -qa | grep mariadb mariadb-libs-5.5.60-1.el7_5.x86_64 4. 卸载mariadb相关 [root@VM_0_13_centos data]# yum remov
阅读全文
posted @ 2018-10-09 16:27
fengjian1585
阅读(1255)
推荐(0)
摘要:
整体架构 bluestore的诞生是为了解决filestore自身维护一套journal并同时还需要基于系统文件系统的写放大问题,并且filestore本身没有对SSD进行优化,因此bluestore相比于filestore主要做了两方面的核心工作: 去掉journal,直接管理裸设备 针对SSD进
阅读全文
posted @ 2018-10-06 16:36
fengjian1585
阅读(2363)
推荐(0)
posted @ 2018-09-30 15:21
fengjian1585
阅读(1532)
推荐(0)
摘要:
突然集群的2个节点挂了,通过top查看, 虚拟内存22G, 通过 pmap -x 8 | grep anon 一大堆64M Linux下glibc的内存管理机制用了一个很奇妙的东西,叫arena。在glibc分配内存的时候,大内存从从中央分配区分配,小内存则在线程创建时,从缓存区分配。为了解决分配内
阅读全文
posted @ 2018-09-30 10:25
fengjian1585
阅读(2661)
推荐(0)
摘要:
需要解决的越来越多, 基础镜像中 添加 cronolog功能,用于切割catalina.out 日志。 思路是: cephfs 挂载在node节点, crontab 删除 几天的tomcaat 日志。 也想把crontab放在基础镜像中,出现服务无法启动镜像 1G,太大了。
阅读全文
posted @ 2018-09-27 15:31
fengjian1585
阅读(451)
推荐(0)
摘要:
系统log 出现 Failed to abandon session scope: Connection timed out 错误, reboot无法重启 解决办法就是让postfix只用IPv4。 打开文件:/etc/postfix/main.cf systemd-logind: Failed t
阅读全文
posted @ 2018-09-18 14:09
fengjian1585
阅读(2013)
推荐(0)
摘要:
ceph 性能测试 1. 测试准备 1.1 磁盘读写性能 1.1.1 单个 OSD 磁盘写性能,大概 165MB/s。 测试发现,其结果变化非常大,有时候上 75,有时是150. 1.1.2 两个OSD同时写性能,大概 18 MB/s。怎么差距那么大呢?几乎是单个磁盘的 1/10 了。 1.1.4
阅读全文
posted @ 2018-09-11 10:18
fengjian1585
阅读(1007)
推荐(0)
摘要:
1. 下载 2. 解压 3.设置环境变量 4. 安装cnpm 由于NMP源都在国外,下载相关资源很慢,所以建议用国内的淘宝NPM镜像(http://npm.taobao.org/) 通过cnmp命令安装的包都会从淘宝NMP下载,速度很快。 编译结果
阅读全文
posted @ 2018-08-29 17:21
fengjian1585
阅读(214)
推荐(0)
摘要:
1. 建立基础镜像 2. tomcat/conf/catalina.sh 添加初始堆参数 **其中 Djava.rmi.server.hostname= 192.168.200.10 为宿主机的IP地址。 3. 加入应用 4. 运行应用docker 5. 使用visualVM监控 二, 2. tom
阅读全文
posted @ 2018-08-28 13:48
fengjian1585
阅读(908)
推荐(0)
摘要:
新安装了redhat7.4安装后,登录系统,使用yum update 更新系统。提示: This system is not registered to Red Hat Subscription Management. You can use subscription-manager to regi
阅读全文
posted @ 2018-08-17 10:28
fengjian1585
阅读(1351)
推荐(0)
摘要:
项目的组件相对比较复杂,原有的一些选项是靠 ConfigMap 以及 istioctl 分别调整的,现在通过重新设计的Helm Chart,安装选项用values.yml或者 helm 命令行的方式来进行集中管理了。 在安装 Istio 之前要确保 Kubernetes 集群(仅支持v1.9及以后版
阅读全文
posted @ 2018-08-15 13:56
fengjian1585
阅读(2221)
推荐(0)
摘要:
容器内部利用脚本来获取容器的CGroup资源限制,并通过设置JVM的Heap大小。 Docker1.7开始将容器cgroup信息挂载到容器中,所以应用可以从 /sys/fs/cgroup/memory/memory.limit_in_bytes 等文件获取内存、 CPU等设置,在容器的应用启动命令中
阅读全文
posted @ 2018-08-13 18:23
fengjian1585
阅读(1959)
推荐(1)
摘要:
JVM系列三:JVM参数设置、分析 不管是YGC还是Full GC,GC过程中都会对导致程序运行中中断,正确的选择不同的GC策略,调整JVM、GC的参数,可以极大的减少由于GC工作,而导致的程序运行中断方面的问题,进而适当的提高Java程序的工作效率。但是调整GC是以个极为复杂的过程,由于各个程序具
阅读全文
posted @ 2018-08-13 18:21
fengjian1585
阅读(259)
推荐(0)
摘要:
kubernetes备份和恢复 备份etcd数据 首先由于ETCD有三个备份,并且会同步,所以您只需要在一台master机器上执行ETCD备份即可。 另外在运行下列命令前,确保当前机器的kube-apiserver是运行的。 ps -ef|grep kube-apiserver执行备份 export
阅读全文
posted @ 2018-08-13 14:48
fengjian1585
阅读(310)
推荐(0)
摘要:
查看node的标签kubectl get node --show-labels删除标签kubectl label nodes node5 storagenode-设置标签kubectl label nodes node5 storagenode=glusterfs修改标签,需要加上--overwri
阅读全文
posted @ 2018-08-08 10:49
fengjian1585
阅读(208)
推荐(0)
摘要:
1. 安装 svn [root@svn conf]# svn --version svn, version 1.7.14 (r1542130) compiled Apr 11 2018, 02:40:28 2.创建仓库 4. 修改仓库的配置文件 由于使用了多个版本仓库,所以用户密码和权限控制 单独提
阅读全文
posted @ 2018-07-31 16:44
fengjian1585
阅读(521)
推荐(0)
摘要:
Maven单独构建多模块项目中的单个模块 说明: 1、可能存在的场景,多模块项目没有互相引用,那么此时可以单独构建单个项目,指定到子模块的pom.xml文件即可完成编译。 2、如果多模块项目各自都引用了,那么单独编译子模块的pom.xml文件会直接报错,解决方法就是编译父项目pom.xml。 3、如
阅读全文
posted @ 2018-07-19 12:10
fengjian1585
阅读(352)
推荐(0)
摘要:
1. Linux运维基础采集项 做运维,不怕出问题,怕的是出了问题,抓不到现场,两眼摸黑。所以,依靠强大的监控系统,收集尽可能多的指标,意义重大。但哪些指标才是有意义的呢,本着从实践中来的思想,各位工程师在长期摸爬滚打中总结出来的经验最有价值。 在各位运维工程师长期的工作实践中,我们总结了在系统运维
阅读全文
posted @ 2018-07-09 09:55
fengjian1585
阅读(797)
推荐(0)
摘要:
一:前言Kubernetes系统在长时间运行后,Kubernetes Node会下载非常多的镜像,其中可能存在很多过期的镜像。同时因为运行大量的容器,容器推出后就变成死亡容器,将数据残留在宿主机上,这样一来,过期镜像和死亡容器都会占用大量的硬盘空间。如果磁盘空间被用光,可能会发生非常糟糕的情况,甚至
阅读全文
posted @ 2018-06-24 18:30
fengjian1585
阅读(733)
推荐(0)