上一页 1 2 3 4 5 6 7 ··· 14 下一页
摘要: redhat 终端提示证书过期 Broadcast message from root@localhost.localdomain Your trial is EXPIRED and no VALID license. Phone Number: 400-706-1825 E-mail Addres 阅读全文
posted @ 2022-08-17 08:44 fengjian1585 阅读(179) 评论(0) 推荐(0)
摘要: nova 报错 403 没有权限 2022-08-11 09:13:54.985 1130 ERROR nova.scheduler.client.report [req-53c51f27-48af-4577-9bf4-09d175a9f9ed - - - - -] [None] Failed to 阅读全文
posted @ 2022-08-11 11:17 fengjian1585 阅读(418) 评论(0) 推荐(0)
摘要: 1. 准备go环境 下载go, 编译kubernetes 要求go大于1.17版本 wget https://golang.google.cn/dl/go1.18.linux-amd64.tar.gz tar -zxvf go1.18.linux-amd64.tar.gz rm /usr/local 阅读全文
posted @ 2022-08-09 11:02 fengjian1585 阅读(223) 评论(0) 推荐(0)
摘要: # my global config global: scrape_interval: 30s # Set the scrape interval to every 15 seconds. Default is every 1 minute. evaluation_interval: 30s # E 阅读全文
posted @ 2022-08-09 10:21 fengjian1585 阅读(76) 评论(0) 推荐(0)
摘要: 1、想要去删除k8s中的一个指定命名空间,刚开始使用命令 kubectl delete ns 命名空间的名字 # 或者使用 kubectl delete ns 命名空间的名字 --force --grace-period=0 使用以上两种命令均无法成功删除命名空间,只会使命名空间的状态为Termin 阅读全文
posted @ 2022-08-06 14:32 fengjian1585 阅读(1608) 评论(0) 推荐(0)
摘要: 查看kubelet进程 修改配置文件,添加 --max-pods=10 [root@node1 ~]# vim /lib/systemd/system/kubelet.service.d/10-kubeadm.conf # Note: This dropin only works with kube 阅读全文
posted @ 2022-07-27 16:23 fengjian1585 阅读(485) 评论(0) 推荐(0)
摘要: 1. node节点维护,驱逐node节点pod kubectl drain node1 --ignore-daemonsets 2. 恢复 kubectl uncordon node1 drain = cordon + evict 判断是否开启超线程 逻辑CPU个数: grep -c process 阅读全文
posted @ 2022-07-26 17:46 fengjian1585 阅读(331) 评论(0) 推荐(0)
摘要: 删除每行开头或者末尾的空格和制表符 [root@localhost ~]# awk '{ sub(/^[ \t]+/, ""); print }' content.txt 删除指定列中 super 和 dirv awk '{ sub(/dirver\/|super\//, ""); print }' 阅读全文
posted @ 2022-07-22 11:17 fengjian1585 阅读(798) 评论(0) 推荐(0)
摘要: 安装k8s 1.24版本,使用yum 安装了crio 出现 /var/log/message 日志中出现了 error adding seccomp filter rule for syscall bdflush : requested action matches default action o 阅读全文
posted @ 2022-07-20 17:21 fengjian1585 阅读(696) 评论(0) 推荐(0)
摘要: controller配置 [root@controller ~]# cat /etc/neutron/neutron.conf [DEFAULT] core_plugin = ml2 service_plugins = router allow_overlapping_ips = true tran 阅读全文
posted @ 2022-07-15 11:37 fengjian1585 阅读(353) 评论(0) 推荐(0)
摘要: 一、测试环境二、查询当前openstack的网络类型三、neutron的配置(controller节点)1. 关闭Linuxbridge服务2. 重建neutron数据库3. 安装openvswitch软件包4. 配置ML2 插件5. 配置ML3 插件6. 配置openvswitch_agent7. 阅读全文
posted @ 2022-07-14 09:29 fengjian1585 阅读(1498) 评论(0) 推荐(0)
摘要: 10.20.1.181 nova-api controller 10.20.1.182 nova-compute compute1 10.20.1.183 nova-compute compute2 实例迁移,需要nova用户在nova-compute 免密钥互通 10.20.1.182 上操作 修 阅读全文
posted @ 2022-07-13 14:40 fengjian1585 阅读(383) 评论(0) 推荐(0)
摘要: 目前openstack场景常用的存储类型主要有cinder、manila和swift三种类型存储。 下面简单介绍三种存储的对比: Cinder:提供块存储服务,可以对接后端存储类型:本地磁盘、ip-san、fc-san、fusionstorage-block Manila:提供文件存储服务,可以对接 阅读全文
posted @ 2022-07-12 13:28 fengjian1585 阅读(1587) 评论(0) 推荐(0)
摘要: openstack 只有两种角色 user 或者 admin 角色 创建域default openstack domain create --description "Default Domain" default 创建 项目名admin openstack project create --dem 阅读全文
posted @ 2022-07-11 20:12 fengjian1585 阅读(1136) 评论(0) 推荐(0)
摘要: 一般命令 raw #发送一个原始的IPMI请求,并且打印回复信息。 Lan #配置网络(lan)信道(channel) chassis #查看底盘的状态和设置电源 event #向BMC发送一个已经定义的事件(event),可用于测试配置的SNMP是否成功 mc #查看MC(Management C 阅读全文
posted @ 2022-07-11 10:29 fengjian1585 阅读(1125) 评论(0) 推荐(0)
摘要: 1. 安装dashboard后, 无法访问 OpenStack Train The requested URL /auth/login/ was not found on this server. 解决:添加 WEBROOT = '/dashboard/'systemctl restart http 阅读全文
posted @ 2022-07-11 09:37 fengjian1585 阅读(382) 评论(0) 推荐(0)
摘要: 安装openstack报错 net_mlx5: cannot load glue library: /lib64/libmlx5.so.1: version `MLX5_1.6' not found (required by /usr/lib64/dpdk-pmds-glue/librte_pmd_ 阅读全文
posted @ 2022-07-10 16:12 fengjian1585 阅读(990) 评论(0) 推荐(0)
摘要: 1. 查看cpu是否支持kvm [root@sorl1 ~]$ grep -E 'vmx|svm' /proc/cpuinfo 2. 查看yum kvm [root@sorl1 ~]# yum list | grep kvm libvirt-daemon-kvm.x86_64 1.2.17-13.e 阅读全文
posted @ 2022-07-03 13:20 fengjian1585 阅读(179) 评论(0) 推荐(0)
摘要: 在RHEL,注册系统使用Red Hat订阅管理,使用您的客户Portal的用户名和密码: # subscription-manager register --username="USERNAME" --password="PASSWORD" 为RHEL系统找到授权池包含这些通道: # subscri 阅读全文
posted @ 2022-06-29 16:45 fengjian1585 阅读(418) 评论(0) 推荐(0)
摘要: NTP 安装及配置 1、统一时区,在所有节点(controller、compute01、compute02)上执行 # ln -sf /usr/share/zoneinfo/Asia/Shanghai /etc/localtime 注:安装时若有选择正确时区,可忽略上述设置 2、在控制节点 cont 阅读全文
posted @ 2022-06-29 16:29 fengjian1585 阅读(784) 评论(0) 推荐(0)
摘要: 容器-promQL语法之内存指标 在容器内进行内存监控的常用指标包括 1、 内存中的cache用量 container_memory_cache 2、 常驻的内存用量 container_memory_rss 3、 交换分区用量 container_memory_swap 4、 内存的总占用量 co 阅读全文
posted @ 2022-06-29 14:29 fengjian1585 阅读(1673) 评论(0) 推荐(0)
摘要: 升级gcc版本,依次执行如下命令: yum -y install centos-release-scl yum -y install devtoolset-9-gcc devtoolset-9-gcc-c++ devtoolset-9-binutilsscl enable devtoolset-9 阅读全文
posted @ 2022-06-28 11:22 fengjian1585 阅读(719) 评论(0) 推荐(0)
摘要: 对于非结构化的数据存储系统来说,LIST 操作通常都是非常重量级的,不仅占用大量的 磁盘 IO、网络带宽和 CPU,而且会影响同时间段的其他请求(尤其是响应延迟要求极高的 选主请求),是集群稳定性的一大杀手。 例如,对于 Ceph 对象存储来说,每个 LIST bucket 请求都需要去多个磁盘中捞 阅读全文
posted @ 2022-06-24 14:37 fengjian1585 阅读(440) 评论(0) 推荐(0)
摘要: 在近期的工作中,我们发现 K8s 集群中有些节点资源使用率很高,有些节点资源使用率很低,我们尝试重新部署应用和驱逐 Pod,发现并不能有效解决负载不均衡问题。在学习了 Kubernetes 调度原理之后,重新调整了 Request 配置,引入了调度插件,才最终解决问题。这篇就来跟大家分享 Kuber 阅读全文
posted @ 2022-06-24 14:23 fengjian1585 阅读(626) 评论(0) 推荐(0)
摘要: gateway,elasticsearch底层的一个module,这个module,你也可以认为是什么呢?认为是es代码中的一个模块 gateway这个模块是负责干什么的,module,java,j2ee,java web,用户管理模块,订单管理模块。。。用户管理模块,就是类似一个module,是用 阅读全文
posted @ 2022-06-20 15:57 fengjian1585 阅读(269) 评论(0) 推荐(0)
摘要: nfs k8s storageclsss 配置 [root@k8s-master-01 tools]# cat nfs_sc.yaml apiVersion: v1 kind: Namespace metadata: name: kubesphere-system apiVersion: v1 ki 阅读全文
posted @ 2022-06-01 21:07 fengjian1585 阅读(406) 评论(0) 推荐(0)
摘要: 深入ingress-nginx 1. 使用deployment 是否合适 2. 四层代理 3. 定制配置(超时, buffersize 设置) 4. https服务 5. 访问控制(session保持,支不支持AB测试) 错误页面是发生错误时显示的网页。错误页面会警告用户发生的错误类型,并可能为用户 阅读全文
posted @ 2022-05-29 18:34 fengjian1585 阅读(958) 评论(0) 推荐(1)
摘要: 下载地址:https://github.com/prometheus-operator/kube-prometheus 安装后, 无法获取 kubectl top pod 监控数据, 经过prometheus 查询 container_cpu_usage_seconds_total, 发现conta 阅读全文
posted @ 2022-05-27 11:03 fengjian1585 阅读(420) 评论(0) 推荐(0)
摘要: 设置tab 补齐方法 vim /etc/profile 前提: 安装了bash-completion.noarch source <(kubectl completion bash) source /etc/profile 阅读全文
posted @ 2022-05-27 09:18 fengjian1585 阅读(84) 评论(0) 推荐(0)
摘要: 一、系统环境Traefik版本: 2.5.6Kubernetes 版本:1.23.3 二、helm 安装2.1 系统环境Kubernetes 1.23+Helm 3.x 2.2 安装添加Traefik chart 仓库 helm repo add traefik https://helm.traef 阅读全文
posted @ 2022-05-16 20:31 fengjian1585 阅读(514) 评论(0) 推荐(0)
摘要: 清除 curl -u admin:123456 -X POST http://192.168.0.202/api/v2.0/system/gc/schedule -H 'accept: application/json' -H 'Content-Type: application/json' -d 阅读全文
posted @ 2022-05-12 19:32 fengjian1585 阅读(432) 评论(0) 推荐(0)
摘要: 生产随机字符串 [root@localhost harbor]# openssl rand -base64 16 Pkxoo3CC7pTD222nxTL6ucRSA== 阅读全文
posted @ 2022-05-12 14:43 fengjian1585 阅读(488) 评论(0) 推荐(0)
摘要: 在实际生产环境中,各种无法预知的事件难以避免,风险隐患无处不在。分布式系统架构的复杂性、海量数据的计算与存储、跨团队协同等,这些都在向系统的稳定性发起挑战。系统不确定性风险的加剧,最终将会波及到我们业务的连续性。 你是否想过:如果整个区域或数据中心出现故障、服务出现访问延迟、系统时钟不同步等这些问题 阅读全文
posted @ 2022-04-21 10:06 fengjian1585 阅读(436) 评论(0) 推荐(0)
摘要: containerd 实现了 kubernetes 的 Container Runtime Interface (CRI) 接口,提供容器运行时核心功能,如镜像管理、容器管理等,相比 dockerd 更加简单、健壮和可移植。 加载模块 cat <<EOF | sudo tee /etc/module 阅读全文
posted @ 2022-04-19 14:30 fengjian1585 阅读(535) 评论(0) 推荐(0)
摘要: 1、查看有多少个IP访问: awk '{print $1}' log_file|sort|uniq|wc -l 2、查看某一个页面被访问的次数: grep "/index.php" log_file | wc -l 3、查看每一个IP访问了多少个页面: awk '{++S[$1]} END {for 阅读全文
posted @ 2022-04-19 09:50 fengjian1585 阅读(190) 评论(0) 推荐(0)
摘要: cri-o 实现了 kubernetes 的 Container Runtime Interface (CRI) 接口,提供容器运行时核心功能,如镜像管理、容器管理等,相比 docker 更加简单、健壮和可移植。 下载 cd /data/tools/ wget https://storage.goo 阅读全文
posted @ 2022-04-18 16:23 fengjian1585 阅读(2614) 评论(0) 推荐(0)
摘要: 1. 备份ifcfg-tns33 [root@jboss1 ~]# cd /etc/sysconfig/network-scripts/ [root@jboss1 network-scripts]# mv ifcfg-ens33 ifcfg-ens33.bak [root@jboss1 networ 阅读全文
posted @ 2022-03-29 12:39 fengjian1585 阅读(111) 评论(0) 推荐(0)
摘要: 下载codis3.2 https://objects.githubusercontent.com/github-production-release-asset-2e65be/25804514/2ab8d92e-053f-11e8-967e-3c733701c706?X-Amz-Algorithm= 阅读全文
posted @ 2022-03-17 17:02 fengjian1585 阅读(774) 评论(0) 推荐(0)
摘要: redis哨兵模式 master redis配置文件 [root@codis-server1 ~]# cat /etc/redis/6379.conf bind 0.0.0.0 protected-mode no port 6379 tcp-backlog 511 timeout 0 tcp-kee 阅读全文
posted @ 2022-03-16 19:04 fengjian1585 阅读(154) 评论(0) 推荐(0)
摘要: 一、JBOSS下载jdk:https://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html jboss:https://developers.redhat.com/products/eap/dow 阅读全文
posted @ 2022-03-15 18:47 fengjian1585 阅读(645) 评论(0) 推荐(1)
上一页 1 2 3 4 5 6 7 ··· 14 下一页