sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2547 Accepted Submission(s): 973

Problem Description
Given a sequence, you’re asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO

Input
The first line of the input has an integer T (1≤T≤10), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m (1≤n≤100000, 1≤m≤5000).
2.The second line contains n positive integers x (1≤x≤100) according to the sequence.

Output
Output T lines, each line print a YES or NO.

Sample Input
2
3 3
1 2 3
5 7
6 6 6 6 6

Sample Output
YES
NO

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
const int maxn=100000+10;
int a[maxn];
int b[5010];
int main() {
    int t;
    cin>>t;
    while(t--) {
        memset(b,0,sizeof(b));
        int n,m;
        cin>>n>>m;
        cin>>a[0];
        a[0]=a[0]%m;
        b[b[0]]++;
        int flag=0;
        for(int i=1;i<n;i++) {
            cin>>a[i];
            a[i]=(a[i]+a[i-1])%m;
            b[a[i]]++;
            if(a[i]==0||b[a[i]]>=2) {
                flag=1;
            }
        }
        if(flag) cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
} 

题解:首先已知:若 x % m = b 且 y % m = b,那么x可以写成x = a1 * m + b,y可以写成y = a2 * m + b,(y - x) % m = ((a2 - a1) * m) % m = 0
当模m后,余数在【0,m)之间,相当于共有m个抽屉,序号从0~m-1,放入m+1个物体,其中必定有两个物体在同一个抽屉之中,利用上述定理得,该序列能整除m