Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
Output
For each case, output a line containing “yes” if is is possible to form a square; otherwise output “no”.
Sample Input
3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5
Sample Output
yes
no
yes

搜边长

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;
int a[25];
int sum,n,s;
bool mark[25];
bool cmp(int a,int b) {
    return a>b;
}
int dfs(int step,int cur,int index) {
    if(step==3) return 1;//ye zi
    for(int i=index;i<n;i++){
        if(!mark[i]) {
            if(cur+a[i]==s) {
                mark[i]=true;
                if(dfs(step+1,0,0)) return 1;
                mark[i]=false;
            }
            else if(cur+a[i]<s){
                mark[i]=true;
                if(dfs(step,cur+a[i],i+1)) return 1;
                mark[i]=false;
            }
        }
    }
    return 0;
}
int main(){
//  freopen("INPut.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--) {
        memset(mark,false,sizeof(mark));
        sum=0;
        scanf("%d",&n);
        int M=0;
        for(int i=0;i<n;i++) {
            scanf("%d",&a[i]);
            sum+=a[i];
            M=max(M,a[i]);
        }
        s=sum/4;
        if(sum%4||M>s) {
            printf("no\n");
            continue;
        }

        sort(a,a+n,cmp);
        if(dfs(0,0,0)) {
            printf("yes\n");
        }
        else printf("no\n");
    }
    return 0;
}