摘要:
x86是指intel的开发的一种32位指令集,从386开始时代开始的,一直沿用至今,是一种cisc指令集,所有intel早期的cpu,amd早期的cpu都支持这种指令集,ntel官方文档里面称为“IA-32” x84_64是x86 CPU开始迈向64位的时候,有2选择:1、向下兼容x86。2、完全重 阅读全文
posted @ 2023-01-28 16:30
牧之丨
阅读(1356)
评论(0)
推荐(0)
摘要:
在Linux中,创建一个文件时,该文件的拥有者都是创建该文件的用户。该文件用户可以修改该文件的拥有者及用户组,root用户可以修改任何文件的拥有者及用户组。 在Linux中,对于文件的权限(rwx),分为三部分,一部分是该文件的拥有者所拥有的权限,一部分是该文件所在用户组的用户所拥有的权限,另一部分 阅读全文
posted @ 2023-01-28 16:26
牧之丨
阅读(5488)
评论(0)
推荐(0)
摘要:
{var:-default_value}当var 不存在,或者值为空时,返回default_value name不存在,返回了一个默认值,但是name并没有改变, 后续不可访问 $ set -u # 打开访问不存在的对象将报错, set +u关闭$ unset name # 删除name$ echo 阅读全文
posted @ 2023-01-20 09:27
牧之丨
阅读(536)
评论(0)
推荐(0)
摘要:
有些开发人员会用Bash来实现很复杂的功能,就像使用别的高级语言一样。他可能觉得自己很牛逼但其他人早就想锤爆他了,Bash的可读性和可维护性远远低于任何高级语言。更要命的是,Bash并没有方便的调试工具和防错机制,出了问题你要排查半天。 在Ruby或者Python等高级语言里,你很容易知道错误是哪行 阅读全文
posted @ 2023-01-20 09:20
牧之丨
阅读(166)
评论(0)
推荐(0)
摘要:
https://nmap.org/ 阅读全文
posted @ 2023-01-13 18:04
牧之丨
阅读(702)
评论(0)
推荐(0)
摘要:
问题: 本人正在使用docker运行一个中型的项目,包含40多个微服务及相关数据库的docker。由于docker-compose up 同时启动的服务过多,超过了请求HTTP限制的60s时间仍未全部成功启动起来,所以出现了超时错误: ERROR: An HTTP request took too 阅读全文
posted @ 2023-01-12 17:08
牧之丨
阅读(535)
评论(0)
推荐(0)
摘要:
原因是因为防火墙关闭之后需要重启docker服务。 执行: service docker restart 即可。 阅读全文
posted @ 2023-01-12 16:39
牧之丨
阅读(281)
评论(0)
推荐(0)
摘要:
出现No route to host 的时候,有如下几种可能: 1、对方的域名确实不通 2、本机自己开了防火墙 3、本机的etc/hosts 里面没有配置本机的机器名和ip (可能性最大) 其中第三点是最猫腻的,在不配置的时候是间断性的(可能1个月都正常,然后突然几天不正常)。修改方案如下: 在结尾 阅读全文
posted @ 2023-01-12 16:38
牧之丨
阅读(7888)
评论(0)
推荐(0)
摘要:
https://www.cnblogs.com/wangzhen-fly/p/11002814.html 前言:想看基于spring 的最简单实现方法,请直接看 第七步。 本文价值在于 包扫描的原理探究和实现 一、背景 项目开发中,使用Netty做服务端,保持长连接与客户端(agent)通讯。Net 阅读全文
posted @ 2023-01-11 18:04
牧之丨
阅读(2041)
评论(0)
推荐(0)
摘要:
现在每次分析网站日志的时候都需要判断百度蜘蛛是不是真实的蜘蛛,nslookup之后需要判断结果中是否包含“baidu”字符串 以下给出一些shell中判断字符串包含的方法,来源程序员问答网站 stackoverflow 以及segmentfault。 方法一:利用grep查找 1 strA="lon 阅读全文
posted @ 2023-01-10 12:00
牧之丨
阅读(725)
评论(0)
推荐(1)
浙公网安备 33010602011771号