1035 Password (20 分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
 

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa
 

Sample Input 2:

1
team110 abcdefg332
 

Sample Output 2:

There is 1 account and no account is modified
 

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333
 

Sample Output 3:

There are 2 accounts and no account is modified

水题
#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
struct mm{
    string name;
    string number;
};
vector<mm> ve;
int main(){
    mm m[maxn];
    int n;
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>m[i].name;
        cin>>m[i].number;
        string st;
        st=m[i].number;
        bool flag=false;
        for(int j=0;j<st.size();j++){
            if(st[j]=='1'){
                st[j]='@';
                flag=true;
            }
            if(st[j]=='0'){
                st[j]='%';
                flag=true;
            }
            if(st[j]=='l'){
                st[j]='L';
                flag=true;
            }
            if(st[j]=='O'){
                st[j]='o';
                flag=true;
            }
        }
        if(flag==true){
            m[i].number=st;
            ve.push_back(m[i]);
        }
    }
    if(ve.size()==0&&n>=2){
        printf("There are %d accounts and no account is modified\n",n);
        return 0;
    }
    else if(ve.size()==0&&n==1){
        printf("There is 1 account and no account is modified\n");
        return 0;
    }
    printf("%d\n",ve.size());
    for(int i=0;i<ve.size();i++){
        cout<<ve[i].name<<" "<<ve[i].number<<endl;
    }
    return 0;
}

 

posted @ 2021-07-01 22:30  XA科研  阅读(29)  评论(0编辑  收藏  举报