1115 Counting Nodes in a BST (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤) which is the size of the input sequence. Then given in the next line are the N integers in [ which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n
 

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28
 

Sample Output:

2 + 4 = 6
 
#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
#define esp 1e-8
#define inf 0x3fffffff
vector<int> v;
typedef struct t{
    int data;
    int level;
    struct t *lchild,*rchild;
}node,*nd;
nd bulid(nd tree,int temp){
    if(tree==NULL){
        tree=new node;
        tree->data=temp;
        tree->lchild=tree->rchild=NULL;
    }else if(temp<=tree->data){
        tree->lchild=bulid(tree->lchild,temp);
    }
    else{
        tree->rchild=bulid(tree->rchild,temp);
    }
    return tree;
}
int maxdepth=-1;
void dfs(nd tree,int depth){
    if(tree==NULL){
        maxdepth=max(depth,maxdepth);
        return ;
    }
    v[depth]++;
    dfs(tree->lchild,depth+1);
    dfs(tree->rchild,depth+1);
}

int main(){
    nd tree=NULL;
    int n,temp;
    cin>>n;
    v.resize(n);
    for(int i=0;i<n;i++){
        scanf("%d",&temp);
        tree=bulid(tree,temp);
    }
    dfs(tree,0);
    printf("%d + %d = %d\n",v[maxdepth-1],v[maxdepth-2],v[maxdepth-1]+v[maxdepth-2]);
    return 0;
}

 

 

 
posted @ 2021-02-24 11:30  XA科研  阅读(66)  评论(0编辑  收藏  举报