HDU To The Max 【最大子阵和】

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
分析:二维最大子阵和,只要把二维的压缩为一维的就行。
code:
View Code
#include<stdio.h>
#include<string.h>
#define min -9999999
int map[110][110];
int sum[110];
int main()
{
int i,j,k,n,tot,max,res;
while(scanf("%d",&n)!=EOF)
{
memset(map,0,sizeof(map));
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
scanf("%d",&map[i][j]);
res=min;
for(i=1;i<=n;i++)
{
memset(sum,0,sizeof(sum));
for(j=i;j<=n;j++) //把二维压缩为一维
{
for(k=1;k<=n;k++)
sum[k]+=map[j][k];
max=min;
tot=0;
for(k=1;k<=n;k++) //一维最大字段和
{
tot+=sum[k];
if(max<tot)
max=tot;
if(tot<0)
tot=0;
}
if(res<max)
res=max;
}
}
printf("%d\n",res);
}
return 0;
}

 
posted @ 2012-03-14 18:04  'wind  阅读(326)  评论(0编辑  收藏  举报