HDU 2845 Beans

Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?
Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
Output
For each case, you just output the MAX qualities you can eat and then get.
Sample Input
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6
Sample Output
242
分析:横竖分别求一下不连续的最大子段和;状态方程: Sum[i]=max(sum[j])+a[i];其中,0<=j<i-1; 
                                        or: sum[i]=max(sum[i-2]+a[i],sum[i-1])
code:
View Code
#include<stdio.h>
#define max(a,b)((a)>(b))?(a):(b)
#define N 200005
int a[N],b[N],dp[N];
int main()
{
int m,n;
int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
scanf("%d",&a[j]);
for(j=2;j<=m;j++)
a[j]=max(a[j-1],a[j-2]+a[j]);
b[i]=a[m];
}
for(j=2;j<=n;j++)
b[j]=max(b[j-1],b[j-2]+b[j]);
printf("%d\n",b[n]);
}
return 0;
}

 
 
posted @ 2012-03-14 18:03  'wind  阅读(307)  评论(0编辑  收藏  举报