HDoj 2602 Bone Collector 01背包

Problem Description

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14
code:
#include<stdio.h>
int a[1001];
int b[1001];
int f[1001];
int main()
{
int n,t,k,v,i,j;
scanf("%d",&t);
for(k=0;k<t;k++)
{
scanf("%d%d",&n,&v);

for(i=0;i<=v;i++)
f[i]=0;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(i=0;i<n;i++)
scanf("%d",&b[i]);
for(i=0;i<n;i++)
for(j=v;j-b[i]>=0;j--)
{
if(f[j]<f[j-b[i]]+a[i])
f[j]=f[j-b[i]]+a[i];
else f[j]=f[j];
}
printf("%d\n",f[v]);
}
return 0;
}

 
posted @ 2012-03-14 07:30  'wind  阅读(380)  评论(0编辑  收藏  举报