最长上升子序列 POJ2533

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 18853   Accepted: 8147

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion
 
题目的大意是:给出一序列,求出该序列的最长上升子序列的最大长度。
思路:用数组a[]存储序列,b[i]表示以a[i]为结尾的序列的最大长度。
因此要求出b[i]的最大值,即求出max{b[0],b[1]....b[i-1]}的最大值,那么b[i]的最大值为max{b[0],b[1]....b[i-1]}+1;
即可写出状态方程:b[i]=max{b[0],b[1].....b[j]}+1;(0<=j<i&&a[j]<a[i]),然后求出数组b[]中的最大值即为所求。
#include<iostream>
using namespace std;

int main(void)
{
	int i,j,n;
	int a[1001];
	int b[1001];
	int max;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&a[i]);
		b[i]=1;
	}
	for(i=0;i<n;i++)
	{
		max=0;
		for(j=0;j<i;j++)
		{
			if(a[i]>a[j]&&b[j]>max)
			{
				max=b[j];
			}
		}
		b[i]=max+1;
	}
	max=0;
	for(i=0;i<n;i++)
	{
		if(max<b[i])
			max=b[i];
	}
	printf("%d\n",max);
	return 0;
}
 
 
posted @ 2011-07-09 23:19  Matrix海子  阅读(3057)  评论(0编辑  收藏  举报