http://acm.hust.edu.cn/vjudge/contest/125004#problem/D

 

Description

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit(1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3

Case 2: 6

Case 3: 12

 

题意:现给出两个数, 第一个数代表要被除的数,而第二个数代表一个数的组成元素(只能由它构成)。现在问你第二个数要用几次,才能够整除第一个数。

(For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. )

 

 

 

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define maxn 110
#define oo 0x3f3f3f3f

int main()
{
    int T, a, b, n, r, cnt=1;
    scanf("%d", &T);

    while(T --)
    {
        int ans = 1;
        scanf("%d %d", &a, &b);
        n = b;
        r = b % a;

        while(r!=0)
        {
            n = r * 10 + b;
            ans ++;
            r = n % a;
        }

        printf("Case %d: %d\n",cnt++, ans);
    }
    return 0;
}
View Code

 

 

 

 

posted on 2016-07-30 21:34  不忧尘世不忧心  阅读(198)  评论(0编辑  收藏  举报