ubuntu12.10下安装Asterisk

  Asterisk是一款GPLv2协议下的开源电话应用平台。简单来说,Asterisk是一个服务器应用,能够完成发起电话呼叫、接受电话呼叫、对电话呼叫进行定制处理。

  首先,来说一下怎样在ubuntu下安装Asterisk,网上已经有许多安装的介绍,很容易安装,在此记录下来,以防忘记。大概方法都差不多。

  第一步:先去官网下载最新的包,准备安装

  第二步:下载下来后,会得到一个.tar.gz后缀的文件,把它放到一个目录下

      tar -zxvf asterisk-11-current.tar.gz     解压

      cd asterisk-11.2.0                              进入到目录下

      ./configure                                         检测环境和配置  ,在此会因为少包而出错,根据提示,安装相应包即可

      直到出现下面的*号为止,环境和配置检测成功

                    

        make clean              清除原来编译所产生的文件

      make all                  重新编译

      会出现下面:

                       

      键入 make install      开始安装

      会出现下面:

      

      根据提示make samples或make progdocs都可以,根据你所要,然后就安装成功了

    第三步:键入下面两个命令,就会进入控制台

      asterisk

                     asterisk -r

  至此,就算安装成功了。

  编译时我所遇到的问题和解决方法:

  1.configure: *** XML documentation will not be available because the ‘libxml2′ development package is missing.

          configure: *** Please run the ‘configure’ script with the ‘–disable-xmldoc’ parameter option

          configure: *** or install the ‘libxml2′ development package.

          解决办法:安装 libxml2-dev,有的说没有用,直接./configure ‘-disable-xmldoc’,不管怎样,我是用第一个就解决了

  2.Warning: Install SQLite3 development packege

          解决办法:sudo apt-get install sqlite3 libsqlite3-dev

  以上是我遇到的两个问题,网上有一些其它的问题,如下:

  3.configure: error: no acceptable C compiler found in $PATH

          解决办法:apt-get install gcc

  4.configure: error: C++ preprocessor “/lib/cpp” fails sanity check

          解决办法:apt-get install g++或者apt-get install build-essential

  5.configure: error: *** termcap support not found (on modern systems, this typically means the ncurses development package is missing)

          解决办法:apt-get install ncurses-dev

 

  http://bbs.voip88.com/

  http://blogs.digium.com/tags/asterisk/

  

 

      

posted @ 2013-01-17 15:48  道痕  阅读(...)  评论(...编辑  收藏