ZOJ 3927 Programming Ability Test

Programming Ability Test (PAT) aims to evaluate objectively, through unified examinations with automatic online judging system, the abilities of testees in programming and algorithm design, hence to evaluate scientifically the programming talents, and to provide the enterprises a reference standard for personnel selection.

The alliance enterprises may have their specific green channel preferential conditions listed at the PAT registration website. Some enterprises also provide “Letter of Introduction” for the testees to download and submit to the human resource department together with the PAT certificate when seeking employments.

Recently, Edward Co.,LTD joins PAT Alliance and sets their green channel preferential conditions to 80 points of PAT Advanced Level. That means you can enter the green channel if you get 80 points or above on PAT Advanced Level. Now Edward Co.,LTD gets the result of all examinees, please tell them whether the examinee can get the chance of entering green channel.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The only line contains four integers ScoreAScoreBScoreC, and ScoreD - the four problems' score of the examinee.(0 <= ScoreA <= 20, 0 <= ScoreBScoreC <= 25, 0 <= ScoreD <= 30)

Output

For each test case, if the examinee gets 80 points or above in total, output "Yes", else output "No".

Sample Input

4
0 0 5 30
20 25 20 0
20 25 20 15
20 25 25 30

Sample Output

No
No
Yes
Yes

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <queue>

using namespace std;
int t;
int a,b,c,d;
int main()
{
	int t;
	while(scanf("%d",&t)!=EOF)
	{
	while(t--)
	{
		scanf("%d%d%d%d",&a,&b,&c,&d);
          if(a+b+c+d>=80)
			  printf("Yes\n");
		  else	
			  printf("No\n");
	}
	}
	return 0;
}


   

posted @ 2016-04-16 10:04  Shendu.CC  阅读(156)  评论(0编辑  收藏  举报