Poj 2082 Terrible Sets

Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5466 Accepted: 2792
Description


Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑0<=j<=i-1wj <= x <= ∑0<=j<=iwj} 
Again, define set S = {A| A = WH for some W , H ∈ R+ and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 
Your mission now. What is Max(S)? 
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 
But for this one, believe me, it's difficult.
Input


The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w1h1+w2h2+...+wnhn < 109.
Output


Simply output Max(S) in a single line for each case.
Sample Input


3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1
Sample Output


12

14

题意,找面积最大的矩形,手滑一下点到讨论区,然后就开心的使用单调栈的模版。

#include<stack>
#include<queue>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<map>
#include<iostream>
#include<string.h>
#include<algorithm>
#define maxn 100000
#define maxm 10000005
#define MAXN 100005
#define MAXM 10005
#define mem(a,b) memset(a,b,sizeof(a))
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
int h[maxn+10];
int l[maxn+10],r[maxn+10];
int st[maxn+10];
int sum[maxn+10];
int n;
void solve(){
    int t=0;
    for(int i=0;i<n;i++){
        while(t>0&&h[st[t-1]]>=h[i]) t--;
        l[i]=t==0?0:(st[t-1]+1);
        st[t++]=i;
    }
    t=0;
    for(int i=n-1;i>=0;i--){
        while(t>0&&h[st[t-1]]>=h[i]) t--;
        r[i]=t==0?n:st[t-1];
        st[t++]=i;
    }
    ll res=0;
    for(int i=0;i<n;i++){
        res=max(res,(ll)h[i]*(sum[r[i]]-sum[l[i]]));
    }
    printf("%lld\n",res);
}
int main(){
    while(~scanf("%d",&n)&&n!=-1){
        mem(st,0);mem(h,0);
        mem(l,0);mem(r,0); mem(sum,0);
        for(int i=0;i<n;i++){
            scanf("%d%d",&sum[i+1],&h[i]);
            sum[i+1]+=sum[i];
        }
        solve();
    }
}

posted @ 2018-05-15 20:41  _大美  阅读(181)  评论(0编辑  收藏  举报