不要过于沉溺过去,也不要过于畅想未来,把握现在!

第一轮 A

 The Coco-Cola Store
Time Limit:1000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Submit Status

Description
Download as PDF

  The Coco-Cola Store 
  Once upon a time, there is a special coco-cola store. If you return three empty bottles to the shop, you'll get a full bottle of coco-cola to drink. If you have n empty bottles right in your hand, how many full bottles of coco-cola can you drink?

Input 
There will be at most 10 test cases, each containing a single line with an integer n ( 1$ \le$n$ \le$100). The input terminates with n = 0, which should not be processed.

Output 
For each test case, print the number of full bottles of coco-cola that you can drink.

Sample Input 

3
10
81
0

Sample Output 

1
5
40


Spoiler

Let me tell you how to drink 5 full bottles with 10 empty bottles: get 3 full bottles with 9 empty bottles, drink them to get 3 empty bottles, and again get a full bottle from them. Now you have 2 empty bottles. Borrow another empty bottle from the shop, then get another full bottle. Drink it, and finally return this empty bottle to the shop!



Problemsetter: Rujia Liu, Special Thanks: Yiming Li & Sohel Hafiz



/*************************************************************************
	> File Name: a.cpp
	> Author: 
	> Mail: 
	> Created Time: 2014年11月08日 星期六 18时13分44秒
 ************************************************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
int a,ans;
int main()
{
    while(1){
        scanf("%d",&a);
        if(!a) break;
        ans=0;
        while(1){
            ans+=a/3;
            a=a-a/3*3+a/3;
            if(a==1) break;
            if(a==2) {ans+=1;break;}
        }
        printf("%d\n",ans);
    }
    return 0;
}


posted @ 2014-11-08 18:33  coding_yuan  阅读(96)  评论(0编辑  收藏  举报

不要过于沉溺过去,也不要过于畅想未来,把握现在!