杭电 Problem 1051 Wooden Sticks 【贪心】

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18020    Accepted Submission(s): 7354


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
2 1 3
 
这一道题排序完了之后要利用一个变量k,第i个要和第i+1个比较。一开始理解错误,用i个与他后面的所有进行比较,结果导致多次WA。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
#include <iostream>
#define MAX_N   5050
#define MAX(a, b) (a > b)? a: b
#define MIN(a, b) (a < b)? a: b
using namespace std;

struct node{
    int l, w;
    bool flag;
}st[MAX_N];

void init() {
    for (int i = 0; i < 5005; i++) {
        st[i].flag = false;
    }
}
int cmp(node a, node b) {
    if (a.l == b.l) return a.w < b.w;
    else return a.l < b.l;
}

int main() {
    int t, n;
    scanf("%d", &t);
    while (t--) {
        scanf("%d", &n);
        init();
        int ans = 0;
        for (int i = 0; i < n; i++) {
            scanf("%d%d", &st[i].l, &st[i].w);
        }
        int k;
        sort(st, st + n, cmp);
        for (int i = 0; i < n; i++) {
            if (st[i].flag) continue;
            ans++;
            k = i;
            for (int j = i + 1; j < n; j++) {
                if (st[j].flag) continue;
                if (st[k].l <= st[j].l && st[k].w <= st[j].w) {
                    st[j].flag = true;
                    k = j;
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


posted @ 2016-07-22 08:36  zprhhs  阅读(165)  评论(0编辑  收藏  举报
Power by awescnb