题目链接

Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input
3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output
3.41

分析:

好久没有敲最小生成树的代码,有点生疏了····

完全的裸的最小生成树,题目要求将所有的点连接起来所需要的最短的路径的长度,也就相当于图的最小生成树。唯一的就是图上给出的是点的坐标,需要将任意的两点之间的距离求出来。

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
struct Node
{
    double x;
    double y;
} node [101];
double tu[101][101],sum;//图,存储的是任意的两点之间的距离
double dis[101];//到该点的最短距离
int vis[101],n;//标记数组,标记一个点是否已经放到最小生成树的集合中
double fun(const Node a,const Node b)//求两点之间的距离
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}


void prim()//裸的prim算法
{
    double  Min;
    sum=0.0;
    int k;
    //默认以0点作为最小生成树的起点
    for(int i=0; i<n; i++)
    {
        dis[i]=tu[0][i];//保存0点到任一点的距离
        vis[i]=0;
    }
    vis[0]=1;//0这个点已经放到最小生成树里面
    for(int i=1; i<n; i++)//构建n-1条边就行了
    {
        Min=0x3f3f3f3f;
        for(int j=0; j<n; j++)//找到最小生成树之外的最小的那条边
        {
            if(vis[j]==0&&dis[j]<Min)
            {
                Min=dis[j];
                k=j;
            }
        }
        //if(Min==0x3f3f3f3f)
        //  break;
        vis[k]=1;
        sum+=Min;
        //printf("%.2lf\n",sum);
        for(int j=0; j<n; j++)
        {
            if(vis[j]==0&&dis[j]>tu[k][j])
                dis[j]=tu[k][j];
        }
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
            scanf("%lf%lf",&node[i].x,&node[i].y);
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                tu[i][j]=0x3f3f3f3f;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
            {
                if(i==j) continue;
                else tu[i][j]=min(tu[i][j],fun(node[i],node[j]));
            }
        }
        prim();
        printf("%.2lf\n",sum);
    }
    return 0;
}
posted on 2018-04-23 20:37  渡……  阅读(317)  评论(0编辑  收藏  举报