IBM websphere6.1 不支持泛型、int-Integer类型的自动装箱和拆箱问题

Websphere6.1默认的JSP编译器为JDK1.3 BT啊!!!!!

所以必须手动更改为1.5,否则不能识别JDK1.5的语法

 解决办法如下:

1、找到 E:\del\WebSphere\AppServer\profiles\BBS\config\cells\0158b9e7271b4d9Node02Cell\applications\BBS2007_war.ear\deployments\BBS2007_war\BBS2007.war\WEB-INF\ibm-web-ext.xmi

在最后面的 </webappext:WebAppExtension> 前添加下面一行:
<jspAttributes xmi:id="JSPAttribute_113" name="jdkSourceLevel" value="15"/>

2、找到E:\del\WebSphere\AppServer\profiles\BBS\installedApps\0158b9e7271b4d9Node02Cell\BBS2007_war.ear\BBS2007.war\WEB-INF\ibm-web-ext.xmi

在最后面的 </webappext:WebAppExtension> 前添加下面一行:
<jspAttributes xmi:id="JSPAttribute_113" name="jdkSourceLevel" value="15"/>

 

然后删除编辑产生的缓存文件,重新启动服务器,一切OK


本文来自CSDN博客,转载请标明出处:http://blog.csdn.net/zsy_gemini/archive/2009/08/17/4456328.aspx

posted @ 2010-09-09 15:29  chinaifne  阅读(474)  评论(0编辑  收藏  举报